aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-30 08:55:25 +0100
committerSam James <sam@gentoo.org>2023-08-30 08:55:28 +0100
commit6fb40bbaf24659ce8d9afd2da3adeff18afb1577 (patch)
tree8bf996a0ef45d9826960e667f2e2aa163fd2ed37
parentsys-boot/syslinux: drop unused eutils (diff)
downloadmusl-6fb40bbaf24659ce8d9afd2da3adeff18afb1577.tar.gz
musl-6fb40bbaf24659ce8d9afd2da3adeff18afb1577.tar.bz2
musl-6fb40bbaf24659ce8d9afd2da3adeff18afb1577.zip
net-fs/cifs-utils: treeclean
::gentoo should be fine. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-fs/cifs-utils/Manifest1
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.7.ebuild124
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.7-heimdal.patch27
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.7-musl-missing-headers.patch25
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.7-talloc.patch29
-rw-r--r--net-fs/cifs-utils/metadata.xml15
6 files changed, 0 insertions, 221 deletions
diff --git a/net-fs/cifs-utils/Manifest b/net-fs/cifs-utils/Manifest
deleted file mode 100644
index 4266d4e9..00000000
--- a/net-fs/cifs-utils/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cifs-utils-6.7.tar.bz2 363647 BLAKE2B 692c4b7de92c2cc5cb88591fb5b5b01ca7d925b105d10f7149e350d1b1661bb6447e71e0ca86095a9e294637d80126e54295413a685786b62c8e70cf26f893d0 SHA512 ee050a0eb4a72fbc8d773e86fbe6839ea2bf11cda5ebd071c8ead66e31b46d50ea4e1d1b26478373be53227cd60b32a90b65b5cb989b5a8237cddfc65bad8e5e
diff --git a/net-fs/cifs-utils/cifs-utils-6.7.ebuild b/net-fs/cifs-utils/cifs-utils-6.7.ebuild
deleted file mode 100644
index 10890bb9..00000000
--- a/net-fs/cifs-utils/cifs-utils-6.7.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils linux-info multilib pam
-
-DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
-HOMEPAGE="https://wiki.samba.org/index.php/LinuxCIFS_utils"
-SRC_URI="https://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ~ppc x86"
-IUSE="+acl +ads +caps +caps-ng creds pam"
-
-RDEPEND="
- !net-fs/mount-cifs
- !<net-fs/samba-3.6_rc1
- sys-apps/keyutils
- ads? (
- sys-libs/talloc
- virtual/krb5
- )
- caps? ( !caps-ng? ( sys-libs/libcap ) )
- caps? ( caps-ng? ( sys-libs/libcap-ng ) )
- pam? ( sys-libs/pam )
-"
-DEPEND="${RDEPEND}"
-PDEPEND="
- acl? ( >=net-fs/samba-4.0.0_alpha1 )
-"
-
-REQUIRED_USE="acl? ( ads )"
-
-DOCS="doc/linux-cifs-client-guide.odt"
-
-PATCHES=(
- "${FILESDIR}/${P}-talloc.patch"
- "${FILESDIR}/${P}-musl-missing-headers.patch"
-)
-
-pkg_setup() {
- linux-info_pkg_setup
-
- if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
- ewarn "You must enable CIFS support in your kernel config, "
- ewarn "to be able to mount samba shares. You can find it at"
- ewarn
- ewarn " File systems"
- ewarn " Network File Systems"
- ewarn " CIFS support"
- ewarn
- ewarn "and recompile your kernel ..."
- fi
-}
-
-src_prepare() {
- default
-
- if has_version app-crypt/heimdal ; then
- # https://bugs.gentoo.org/612584
- eapply "${FILESDIR}/${PN}-6.7-heimdal.patch"
- fi
-
- eautoreconf
-}
-
-src_configure() {
- ROOTSBINDIR="${EPREFIX}"/sbin \
- econf \
- $(use_enable acl cifsacl cifsidmap) \
- $(use_enable ads cifsupcall) \
- $(use caps && use_with !caps-ng libcap || echo --without-libcap) \
- $(use caps && use_with caps-ng libcap-ng || echo --without-libcap-ng) \
- $(use_enable creds cifscreds) \
- $(use_enable pam) \
- $(use_with pam pamdir $(getpam_mod_dir))
-}
-
-src_install() {
- default
-
- # remove empty directories
- find "${ED}" -type d -print0 | xargs --null rmdir \
- --ignore-fail-on-non-empty &>/dev/null
-
- if use acl ; then
- dodir /etc/cifs-utils
- dosym /usr/$(get_libdir)/cifs-utils/idmapwb.so \
- /etc/cifs-utils/idmap-plugin
- dodir /etc/request-key.d
- echo 'create cifs.idmap * * /usr/sbin/cifs.idmap %k' \
- > "${ED}/etc/request-key.d/cifs.idmap.conf"
- fi
-
- if use ads ; then
- dodir /etc/request-key.d
- echo 'create dns_resolver * * /usr/sbin/cifs.upcall %k' \
- > "${ED}/etc/request-key.d/cifs.upcall.conf"
- echo 'create cifs.spnego * * /usr/sbin/cifs.upcall %k' \
- > "${ED}/etc/request-key.d/cifs.spnego.conf"
- fi
-}
-
-pkg_postinst() {
- # Inform about set-user-ID bit of mount.cifs
- ewarn "setuid use flag was dropped due to multiple security implications"
- ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
- ewarn "You are free to set setuid flags by yourself"
-
- # Inform about upcall usage
- if use acl ; then
- einfo "The cifs.idmap utility has been enabled by creating the"
- einfo "configuration file /etc/request-key.d/cifs.idmap.conf"
- einfo "This enables you to get and set CIFS acls."
- fi
-
- if use ads ; then
- einfo "The cifs.upcall utility has been enabled by creating the"
- einfo "configuration file /etc/request-key.d/cifs.upcall.conf"
- einfo "This enables you to mount DFS shares."
- fi
-}
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.7-heimdal.patch b/net-fs/cifs-utils/files/cifs-utils-6.7-heimdal.patch
deleted file mode 100644
index f8fea48f..00000000
--- a/net-fs/cifs-utils/files/cifs-utils-6.7-heimdal.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://bugs.gentoo.org/612584
-
---- cifs-utils-6.7/cifs.upcall.c
-+++ cifs-utils-6.7/cifs.upcall.c
-@@ -75,11 +75,13 @@
- #define KRB5_KEY_LENGTH(k) ((k)->keyvalue.length)
- #define KRB5_KEY_DATA(k) ((k)->keyvalue.data)
- #define KRB5_KEY_DATA_CAST void
-+#define KRB5_FREE_STRING(c,k) krb5_xfree(k)
- #else /* MIT */
- #define KRB5_KEY_TYPE(k) ((k)->enctype)
- #define KRB5_KEY_LENGTH(k) ((k)->length)
- #define KRB5_KEY_DATA(k) ((k)->contents)
- #define KRB5_KEY_DATA_CAST krb5_octet
-+#define KRB5_FREE_STRING(c,k) krb5_free_string(c,k)
- #endif
-
- #ifdef HAVE_LIBCAP_NG
-@@ -358,7 +360,7 @@
- syslog(LOG_DEBUG, "%s: krb5_cc_get_full_name failed: %d\n", __func__, ret);
- } else {
- syslog(LOG_DEBUG, "%s: default ccache is %s\n", __func__, cachename);
-- krb5_free_string(context, cachename);
-+ KRB5_FREE_STRING(context, cachename);
- }
-
- if (!get_tgt_time(cc)) {
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.7-musl-missing-headers.patch b/net-fs/cifs-utils/files/cifs-utils-6.7-musl-missing-headers.patch
deleted file mode 100644
index cfb54e28..00000000
--- a/net-fs/cifs-utils/files/cifs-utils-6.7-musl-missing-headers.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Naur cifs-utils-6.7.orig/getcifsacl.c cifs-utils-6.7/getcifsacl.c
---- cifs-utils-6.7.orig/getcifsacl.c 2017-03-02 16:51:05.000000000 -0000
-+++ cifs-utils-6.7/getcifsacl.c 2019-05-11 14:18:04.522455988 -0000
-@@ -35,6 +35,9 @@
- #include <limits.h>
- #include <ctype.h>
- #include <sys/xattr.h>
-+#include <linux/limits.h>
-+#include <endian.h>
-+
- #include "cifsacl.h"
- #include "idmap_plugin.h"
-
-diff -Naur cifs-utils-6.7.orig/setcifsacl.c cifs-utils-6.7/setcifsacl.c
---- cifs-utils-6.7.orig/setcifsacl.c 2017-03-02 16:51:05.000000000 -0000
-+++ cifs-utils-6.7/setcifsacl.c 2019-05-11 14:17:58.285761823 -0000
-@@ -35,6 +35,8 @@
- #include <limits.h>
- #include <ctype.h>
- #include <sys/xattr.h>
-+#include <linux/limits.h>
-+#include <endian.h>
-
- #include "cifsacl.h"
- #include "idmap_plugin.h"
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.7-talloc.patch b/net-fs/cifs-utils/files/cifs-utils-6.7-talloc.patch
deleted file mode 100644
index 7e341863..00000000
--- a/net-fs/cifs-utils/files/cifs-utils-6.7-talloc.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=612018
-
-From: Thomas Witt <pyromaniac@exherbo.org>
-Date: Wed, 15 Mar 2017 20:20:44 +0000 (+0000)
-Subject: mount.cifs: Remove data_blob.h include
-X-Git-Url: https://git.samba.org/?p=cifs-utils.git;a=commitdiff_plain;h=272d523a57a4e8791d625a479128613be5e401f5
-
-mount.cifs: Remove data_blob.h include
-
-data_blob.h includes talloc.h from libtalloc, but that is only marked as
-a dependency for cifs.upcall. No symbols from that header are used by
-cifs.mount, so remove it to avoid the libtalloc dependency
-
-Signed-off-by: Thomas Witt <pyromaniac@exherbo.org>
----
-
-diff --git a/mount.cifs.c b/mount.cifs.c
-index 13b71ef..2612feb 100644
---- a/mount.cifs.c
-+++ b/mount.cifs.c
-@@ -61,7 +61,6 @@
- #include "mount.h"
- #include "util.h"
- #include "resolve_host.h"
--#include "data_blob.h"
-
- #ifndef MS_MOVE
- #define MS_MOVE 8192
-
diff --git a/net-fs/cifs-utils/metadata.xml b/net-fs/cifs-utils/metadata.xml
deleted file mode 100644
index 3f2586b1..00000000
--- a/net-fs/cifs-utils/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>samba@gentoo.org</email>
- <name>Samba Team</name>
- </maintainer>
- <longdescription>The in-kernel CIFS filesystem relies on a set of user-space tools. That package of tools is called cifs-utils. Although not really part of Samba proper, these tools were originally part of the Samba package. For several reasons, shipping these tools as part of Samba was problematic and it was deemed better to split them off into their own package</longdescription>
- <use>
- <flag name="ads">Enable Active Directory support and create cifs.idmap binary - idmap support</flag>
- <flag name="caps">libcap support</flag>
- <flag name="caps-ng">libcap-ng support</flag>
- <flag name="creds">cifs credentials support</flag>
- </use>
-</pkgmetadata>