aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorxdch47 <xdch47@posteo.de>2018-11-18 20:26:24 +0100
committerAnthony G. Basile <blueness@gentoo.org>2018-11-18 15:22:34 -0500
commit89ad3152c133ea64b34c4e84911ef76f6237d04a (patch)
treeb5a1674e257016fb0eda7d63f5924df6ffebea18
parentnet-misc/whois: version bump (diff)
downloadmusl-89ad3152c133ea64b34c4e84911ef76f6237d04a.tar.gz
musl-89ad3152c133ea64b34c4e84911ef76f6237d04a.tar.bz2
musl-89ad3152c133ea64b34c4e84911ef76f6237d04a.zip
net-fs/samba: version bump to 4.9.2-r1
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Manifest-Sign-Key: 0DEDF1A904568BAD1FC45C283DCC44782ED07E1C Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--net-fs/samba/files/samba-4.9.2-timespec.patch21
-rw-r--r--net-fs/samba/samba-4.9.2-r1.ebuild (renamed from net-fs/samba/samba-4.9.2.ebuild)9
2 files changed, 27 insertions, 3 deletions
diff --git a/net-fs/samba/files/samba-4.9.2-timespec.patch b/net-fs/samba/files/samba-4.9.2-timespec.patch
new file mode 100644
index 00000000..c82f4af4
--- /dev/null
+++ b/net-fs/samba/files/samba-4.9.2-timespec.patch
@@ -0,0 +1,21 @@
+From 11e8c14b78e2423041f3846882f74cd6490a3e44 Mon Sep 17 00:00:00 2001
+From: Joan Karadimov <joan@profuzdigital.com>
+Date: Thu, 18 Oct 2018 18:16:17 +0300
+Subject: [PATCH] Fix compatibility issues with the timespec struct
+
+---
+ source3/include/libsmbclient.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/source3/include/libsmbclient.h b/source3/include/libsmbclient.h
+index 5e4a1715402..6487ea7a8aa 100644
+--- a/source3/include/libsmbclient.h
++++ b/source3/include/libsmbclient.h
+@@ -78,6 +78,7 @@ extern "C" {
+ #include <sys/statvfs.h>
+ #include <stdint.h>
+ #include <fcntl.h>
++#include <time.h>
+ #include <utime.h>
+
+ #define SMBC_BASE_FD 10000 /* smallest file descriptor returned */
diff --git a/net-fs/samba/samba-4.9.2.ebuild b/net-fs/samba/samba-4.9.2-r1.ebuild
index 21c71a20..34d9cd91 100644
--- a/net-fs/samba/samba-4.9.2.ebuild
+++ b/net-fs/samba/samba-4.9.2-r1.ebuild
@@ -15,7 +15,7 @@ SRC_PATH="stable"
SRC_URI="mirror://samba/${SRC_PATH}/${MY_P}.tar.gz"
[[ ${PV} = *_rc* ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
DESCRIPTION="Samba Suite Version 4"
HOMEPAGE="https://www.samba.org/"
@@ -132,6 +132,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}/${PN}-4.4.0-pam.patch"
"${FILESDIR}/${PN}-4.5.1-compile_et_fix.patch"
+ "${FILESDIR}/${PN}-4.9.2-timespec.patch"
"${FILESDIR}/netdb-defines.patch"
)
@@ -159,7 +160,9 @@ src_prepare() {
sed -i -e '/"dns.resolver":/d' "${S}"/third_party/wscript || die
# unbundle iso8601 unless tests are enabled
- use test || sed -i -e '/"iso8601":/d' "${S}"/third_party/wscript || die
+ if ! use test ; then
+ sed -i -e '/"iso8601":/d' "${S}"/third_party/wscript || die
+ fi
# ugly hackaround for bug #592502
cp /usr/include/tevent_internal.h "${S}"/lib/tevent/ || die
@@ -232,7 +235,7 @@ multilib_src_install() {
waf-utils_src_install
# Make all .so files executable
- find "${ED}" -type f -name "*.so" -exec chmod +x {} +
+ find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die
if multilib_is_native_abi ; then
# install ldap schema for server (bug #491002)