aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstefson <herrtimson@yahoo.de>2018-02-02 17:08:26 +0100
committerstefson <herrtimson@yahoo.de>2018-02-02 17:08:26 +0100
commitacc9ccf2b2a378825b1d196481f7fcbe2cb6a5da (patch)
tree233147eda7d3aee5338875e6fc418bc32d9477d2
parentdev-lang/rust: attempt to make the build system to honor MAKEOPTS from make.conf (diff)
downloadmusl-acc9ccf2b2a378825b1d196481f7fcbe2cb6a5da.tar.gz
musl-acc9ccf2b2a378825b1d196481f7fcbe2cb6a5da.tar.bz2
musl-acc9ccf2b2a378825b1d196481f7fcbe2cb6a5da.zip
dev-lang/rust: attempt to fix MAKEOPTS during src_install as well
-rw-r--r--dev-lang/rust/rust-1.23.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.23.0-r1.ebuild b/dev-lang/rust/rust-1.23.0-r1.ebuild
index c5b5ff43..d648ba01 100644
--- a/dev-lang/rust/rust-1.23.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.23.0-r1.ebuild
@@ -193,7 +193,7 @@ src_compile() {
}
src_install() {
- env DESTDIR="${D}" ./x.py install || die
+ env DESTDIR="${D}" ./x.py install -j$(makeopts_jobs) || die
rm "${D}/usr/$(get_libdir)/rustlib/components" || die
rm "${D}/usr/$(get_libdir)/rustlib/install.log" || die