aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-06-28 13:09:27 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-06-28 13:09:27 -0400
commitaf17d2ed1ab5879c1f2d52fe92797cb0d19d3a38 (patch)
treef7963ded252f556544c3426b589450a06e5b691c
parentnet-fs/samba: Mark 4.11.8 stable (diff)
downloadmusl-af17d2ed1ab5879c1f2d52fe92797cb0d19d3a38.tar.gz
musl-af17d2ed1ab5879c1f2d52fe92797cb0d19d3a38.tar.bz2
musl-af17d2ed1ab5879c1f2d52fe92797cb0d19d3a38.zip
net-misc/rsync: version bump to 3.2.0-r1
Package-Manager: Portage-2.3.99, Repoman-2.3.23 RepoMan-Options: --force Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--net-misc/rsync/Manifest1
-rw-r--r--net-misc/rsync/rsync-3.2.0-r1.ebuild157
2 files changed, 158 insertions, 0 deletions
diff --git a/net-misc/rsync/Manifest b/net-misc/rsync/Manifest
index 829c80d4..12fd2dd6 100644
--- a/net-misc/rsync/Manifest
+++ b/net-misc/rsync/Manifest
@@ -1 +1,2 @@
DIST rsync-3.1.3.tar.gz 905908 BLAKE2B 616a1f3239327a28b881310f5f249c90b8bcdb05091279cd62f9cb4e35a8428c7cdd9b89e711ba124601a738f0deb9bfbebafba7fd88b72866476138a9f8c75a SHA512 8385f4c0ea37e7a1da3cf45794154f5bc4d1c49bc625ba3b5f85adaf3eafe6d71c15bdcb1410bde731e5d4c19aff3331606637462fa27a68dc3e13192dd78f99
+DIST rsync-3.2.0.tar.gz 1048009 BLAKE2B 641be077a88958a09b083fd9658ae7f40ce3565bee1959f0c7ef82c61356a070e7ca1e0ceeb96b7a1b31a5ee031a84733ade3965aaa93f9e18795df16a6c1460 SHA512 01a109e1e061bb7f4734b694e1f15a83efdd8fcb1995e5eeea75a8d245eead4412c09b37b0fcdfe522e368673768e4fa5ed8891ccf3ae42f60293e4e68d506c2
diff --git a/net-misc/rsync/rsync-3.2.0-r1.ebuild b/net-misc/rsync/rsync-3.2.0-r1.ebuild
new file mode 100644
index 00000000..7c3b9966
--- /dev/null
+++ b/net-misc/rsync/rsync-3.2.0-r1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic prefix systemd
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="https://rsync.samba.org/"
+if [[ "${PV}" == *9999 ]] ; then
+ PYTHON_COMPAT=( python3_{6,7,8} )
+ inherit git-r3 python-any-r1
+ EGIT_REPO_URI="https://github.com/WayneD/rsync.git"
+else
+ if [[ "${PV}" == *_pre* ]] ; then
+ SRC_DIR="src-previews"
+ else
+ SRC_DIR="src"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+ fi
+ SRC_URI="https://rsync.samba.org/ftp/rsync/${SRC_DIR}/${P/_/}.tar.gz"
+ S="${WORKDIR}/${P/_/}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE_CPU_FLAGS_X86=" sse2"
+IUSE="acl examples iconv ipv6 libressl lz4 ssl static stunnel system-zlib xattr xxhash zstd"
+IUSE+=" ${IUSE_CPU_FLAGS_X86// / cpu_flags_x86_}"
+
+LIB_DEPEND="acl? ( virtual/acl[static-libs(+)] )
+ lz4? ( app-arch/lz4[static-libs(+)] )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)] )
+ )
+ system-zlib? ( sys-libs/zlib[static-libs(+)] )
+ xattr? ( kernel_linux? ( sys-apps/attr[static-libs(+)] ) )
+ xxhash? ( dev-libs/xxhash[static-libs(+)] )
+ zstd? ( app-arch/zstd[static-libs(+)] )
+ >=dev-libs/popt-1.5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+if [[ "${PV}" == *9999 ]] ; then
+ BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ ')"
+fi
+
+# Only required for live ebuild
+python_check_deps() {
+ has_version "dev-python/commonmark[${PYTHON_USEDEP}]"
+}
+
+PATCHES=(
+ "${FILESDIR}/${P}-simd_check.patch"
+ "${FILESDIR}/${P}-noexecstack.patch" #728882
+ "${FILESDIR}"/${PN}-fix-musl-ipv6.patch
+)
+
+src_prepare() {
+ default
+
+ eaclocal -I m4
+ eautoconf -o configure.sh
+ eautoheader && touch config.h.in
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myeconfargs=(
+ --with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
+ --without-included-popt
+ $(use_enable acl acl-support)
+ $(use_enable iconv)
+ $(use_enable ipv6)
+ $(use_enable lz4)
+ $(use_enable ssl openssl)
+ $(use_with !system-zlib included-zlib)
+ $(use_enable xattr xattr-support)
+ $(use_enable xxhash)
+ $(use_enable zstd)
+ )
+
+ if [[ "${ARCH}" == "amd64" ]] ; then
+ # SIMD is only available for x86_64 right now (#728868)
+ myeconfargs+=( $(use_enable cpu_flags_x86_sse2 simd) )
+ else
+ myeconfargs+=( --disable-simd )
+ fi
+
+ econf "${myeconfargs[@]}"
+ [[ "${PV}" == *9999 ]] || touch proto.h-tstamp #421625
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d-r1 rsyncd
+
+ dodoc NEWS.md OLDNEWS.md README.md TODO tech_report.tex
+
+ insinto /etc
+ newins "${FILESDIR}"/rsyncd.conf-3.0.9-r1 rsyncd.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rsyncd.logrotate rsyncd
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd-3.0.9-r1 rsyncd
+
+ # Install stunnel helpers
+ if use stunnel ; then
+ emake DESTDIR="${D}" install-ssl-daemon
+ fi
+
+ # Install the useful contrib scripts
+ if use examples ; then
+ exeinto /usr/share/rsync
+ doexe support/*
+ rm -f "${ED}"/usr/share/rsync/{Makefile*,*.c}
+ fi
+
+ eprefixify "${ED}"/etc/{,xinetd.d}/rsyncd*
+
+ systemd_dounit "${FILESDIR}/rsyncd.service"
+}
+
+pkg_postinst() {
+ if egrep -qis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
+ "${EROOT}"/etc/rsyncd.conf "${EROOT}"/etc/rsync/rsyncd.conf ; then
+ ewarn "You have disabled chroot support in your rsyncd.conf. This"
+ ewarn "is a security risk which you should fix. Please check your"
+ ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
+ fi
+ if use stunnel ; then
+ einfo "Please install \">=net-misc/stunnel-4\" in order to use stunnel feature."
+ einfo
+ einfo "You maybe have to update the certificates configured in"
+ einfo "${EROOT}/etc/stunnel/rsync.conf"
+ fi
+ if use system-zlib ; then
+ ewarn "Using system-zlib is incompatible with <rsync-3.1.1 when"
+ ewarn "using the --compress option."
+ ewarn
+ ewarn "When syncing with >=rsync-3.1.1 built with bundled zlib,"
+ ewarn "and the --compress option, add --new-compress (-zz)."
+ ewarn
+ ewarn "For syncing the portage tree, add:"
+ ewarn "PORTAGE_RSYNC_EXTRA_OPTS=\"--new-compress\" to make.conf"
+ fi
+}