aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-01-08 12:55:51 -0800
committerAric Belsito <lluixhi@gmail.com>2017-01-08 12:55:51 -0800
commit7c3561beac52abdb69345941f3d2682ebf9229f0 (patch)
tree34923a3fb82263a770b3a47fadef3a0b56bb3eb2 /app-arch
parentsys-libs/musl-fts: New package (diff)
downloadmusl-7c3561beac52abdb69345941f3d2682ebf9229f0.tar.gz
musl-7c3561beac52abdb69345941f3d2682ebf9229f0.tar.bz2
musl-7c3561beac52abdb69345941f3d2682ebf9229f0.zip
app-arch/pax: Add 20160306
Even though pax is patched in the tree there are a couple of issues. 1. The patch is not actually applied because epatch is never called 2. The linking order is wrong so fts is never linked in. This is being imported with a dependency on musl-fts to override the version in the tree.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pax/Manifest4
-rw-r--r--app-arch/pax/files/pax-20160306-glibc-to-linux.patch38
-rw-r--r--app-arch/pax/metadata.xml5
-rw-r--r--app-arch/pax/pax-20160306.ebuild63
4 files changed, 110 insertions, 0 deletions
diff --git a/app-arch/pax/Manifest b/app-arch/pax/Manifest
new file mode 100644
index 00000000..b1d6fa2f
--- /dev/null
+++ b/app-arch/pax/Manifest
@@ -0,0 +1,4 @@
+AUX pax-20160306-glibc-to-linux.patch 932 SHA256 5dd64a70e394c15de0be8d9c4c2a366cb4cd998c2e32611dd0aced799a2c18e3 SHA512 96d018bd1be2b0d22c9c5e11a92d8cf7ef9bc72d1b13686e572aa15935f2fda9d507baf1e0eb916fec776c2f9d7bab458c203cab64446eed34b70f544109d1d7 WHIRLPOOL a9362fe33bd93532a123b35b4b12b97890b863035773dbcd79820cd7eb4ce4536c46fcff47a8d3947676ee166a4e10e62c1ccc84423ab3ee40d97d91fc67df1e
+DIST paxmirabilis-20160306.cpio.gz 147448 SHA256 4e36fabfabc01a15e0d01eee0306cef79a7f374586f46254dae139eb866ae81b SHA512 65c9613f235d973f23d829d87b93963f4b21beca4d7158abb8243f7f0ba8eb883544bbd0c16bde82f0e55ab2fbf33e3dfb155a50c0f5be3bf6d88eaf95e1037f WHIRLPOOL 5945f45cc69cfd25d7754a9b6b25db98170de2fc926ffe3a661402d95bc41517e40ff059998d682cc65e32fd7e70a78e222525012eb98dde54c1d67c0c6c2277
+EBUILD pax-20160306.ebuild 1448 SHA256 a5004bcd662ead8e2047922f6527f4fdf3fb4d0b80dddb15fe1f834e61825781 SHA512 60629b46c2ce23eb5e060a198deac7857a3614afb298bedbce67d30b36285ba0105f0be2c911a6146055b1fe6498dadacab039f4bf846bb9a63c0dfe62f11cbf WHIRLPOOL 740b7ce6f76c2e608950226be9fd92e927b75104bf33378e5f7f977a875171b715b5a34c2929d1eb1170cd27a92a31f2c6bda16695641799e793b0565d5eeced
+MISC metadata.xml 166 SHA256 2caff447f5bd2701d8456ada5cc633c41ef4373fa4bfeabeb73599d40bcc941b SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84 WHIRLPOOL 1ff70497eca6531f0e0614c72a19f4b8e5ff486a58d369f4f0b36308d1d6b01168f9da887740e3b9f536236be251d3fe05f904d27a9233a7cf613416ba882968
diff --git a/app-arch/pax/files/pax-20160306-glibc-to-linux.patch b/app-arch/pax/files/pax-20160306-glibc-to-linux.patch
new file mode 100644
index 00000000..f864729c
--- /dev/null
+++ b/app-arch/pax/files/pax-20160306-glibc-to-linux.patch
@@ -0,0 +1,38 @@
+--- pax/cache.c.old 2016-03-06 08:12:52.000000000 -0600
++++ pax/cache.c 2016-04-17 13:01:26.461307830 -0500
+@@ -195,7 +195,7 @@
+ * No entry for this uid, we will add it
+ */
+ if (!pwopn) {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) || defined(__linux__)
+ setpwent();
+ #elif !defined(__INTERIX)
+ setpassent(1);
+@@ -265,7 +265,7 @@
+ * No entry for this gid, we will add it
+ */
+ if (!gropn) {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) || defined(__linux__)
+ setgrent();
+ #elif !defined(__INTERIX) && !defined(__CYGWIN__)
+ setgroupent(1);
+@@ -336,7 +336,7 @@
+ }
+
+ if (!pwopn) {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) || defined(__linux__)
+ setpwent();
+ #elif !defined(__INTERIX)
+ setpassent(1);
+@@ -403,7 +403,7 @@
+ }
+
+ if (!gropn) {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) || defined(__linux__)
+ setgrent();
+ #elif !defined(__INTERIX) && !defined(__CYGWIN__)
+ setgroupent(1);
diff --git a/app-arch/pax/metadata.xml b/app-arch/pax/metadata.xml
new file mode 100644
index 00000000..6f49eba8
--- /dev/null
+++ b/app-arch/pax/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-arch/pax/pax-20160306.ebuild b/app-arch/pax/pax-20160306.ebuild
new file mode 100644
index 00000000..753f6854
--- /dev/null
+++ b/app-arch/pax/pax-20160306.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit unpacker toolchain-funcs flag-o-matic
+
+DESCRIPTION="pax (Portable Archive eXchange) is the POSIX standard archive tool"
+HOMEPAGE="https://www.mirbsd.org/pax.htm"
+SRC_URI="https://www.mirbsd.org/MirOS/dist/mir/cpio/paxmirabilis-${PV}.cpio.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libbsd
+elibc_musl? ( sys-libs/musl-fts )"
+DEPEND="${RDEPEND}
+ $(unpacker_src_uri_depends)"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}/${P}-glibc-to-linux.patch" )
+
+src_prepare() {
+ # Newer C libraries omit this include from sys/types.h.
+ sed -i '1i#include <sys/sysmacros.h>' extern.h || die
+ default
+
+ epatch "${PATCHES[@]}"
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ use elibc_musl && append-ldflags "-lfts"
+
+ # We can't rely on LFS flags as it uses the fts.h interface which lacks 64-bit support.
+ set -- \
+ ${CC} ${CPPFLAGS} ${CFLAGS} \
+ -DHAVE_STRLCPY -DHAVE_VIS -DHAVE_STRMODE \
+ -DLONG_OFF_T -DHAVE_LINKAT \
+ $(${PKG_CONFIG} --cflags libbsd-overlay) \
+ -Wall *.c -o ${PN} ${LDFLAGS} \
+ $(${PKG_CONFIG} --libs libbsd-overlay)
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+
+ dosym pax /usr/bin/paxcpio
+ newman cpio.1 paxcpio.1
+
+ dosym pax /usr/bin/paxtar
+ newman tar.1 paxtar.1
+}