aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-10-31 16:13:35 -0700
committerAric Belsito <lluixhi@gmail.com>2016-10-31 16:13:35 -0700
commit64ee8fa9eb1176ca8f1f0082200a0ad35f5922c1 (patch)
tree4a7e800391c26fdef9af256b9654b874da7887eb /app-crypt
parentapp-accessibility/speech-dispatcher: Add stable. (diff)
downloadmusl-64ee8fa9eb1176ca8f1f0082200a0ad35f5922c1.tar.gz
musl-64ee8fa9eb1176ca8f1f0082200a0ad35f5922c1.tar.bz2
musl-64ee8fa9eb1176ca8f1f0082200a0ad35f5922c1.zip
app-crypt/chntpw: Add Latest.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/chntpw/Manifest4
-rw-r--r--app-crypt/chntpw/chntpw-140201.ebuild52
-rw-r--r--app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch11
-rw-r--r--app-crypt/chntpw/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/app-crypt/chntpw/Manifest b/app-crypt/chntpw/Manifest
new file mode 100644
index 00000000..a83d7cfa
--- /dev/null
+++ b/app-crypt/chntpw/Manifest
@@ -0,0 +1,4 @@
+AUX chntpw-140201-missing-stdint.patch 363 SHA256 22d8319807cec29ac9f7f64a5d94ba8edc09dfee94ccc4303e4d39f011ba4ea1 SHA512 44c06ba580c8beba76d84bcbc2bb1b47cfdad44736518f3e9adab13476c0b8a1e6bb64ccdf81aa515daac5e68b52af4f14edac139cbf3ecd558c556248e6df63 WHIRLPOOL ead7efc702e46130ef9ccc501f7486d5029e34c6fc69fbb985564055b8acb7cb43e4bb01a2e24c8f0d95ae91c7b9f53d59478b6ce2e4583cc42d72292376e5c6
+DIST chntpw-source-140201.zip 1404098 SHA256 96e20905443e24cba2f21e51162df71dd993a1c02bfa12b1be2d0801a4ee2ccc SHA512 a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa WHIRLPOOL 87284c123d2ae1965d069d4d97cda23ce757305b3521f84089e43a9f1fa8aaa48f8fbad5bba19b3a439cfb16d270e0f77f528664fdba895c65c100492eb9e42a
+EBUILD chntpw-140201.ebuild 1086 SHA256 528c3745f581829953d9c1a344ca6ba02333f45e0dc4332ce2844f5e37f46ea8 SHA512 43a0528edd558b4e4607f915d62c665182493a2e184135bcf93daeb196e923d81b69e48353b1702bda603cae1f4879df2a1a12f9e919579b314d01efb9444875 WHIRLPOOL a1007a0989f511d18aae18090f63665414507f4bbb94dc2c99de77cf41db871353954f7a78f90524be999b201a35f0c00379a9e7ac5c3e4c375c985b6e6da13d
+MISC metadata.xml 240 SHA256 d1d2aa7abc46b180b2494a0cbb393768f12073097a3ddf9d118cb9e2cead8317 SHA512 e94cdc08f1a8aafc0ec72615a476ed63dbacd22b48413a938f5bfbe9c2bda2cab2347465df3035b53031e0a4f935b47d22fad8c89a67e5780a5370ec9564d99d WHIRLPOOL aad153df696809789d129412e71fd5eca91f7b230c22a10c70baa6f79e3ab57cf8890540fead3d9587f76b4396a7089921b207165fe0505917ad76b5cf86af90
diff --git a/app-crypt/chntpw/chntpw-140201.ebuild b/app-crypt/chntpw/chntpw-140201.ebuild
new file mode 100644
index 00000000..5047f17e
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-140201.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libressl static"
+
+RDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ static? ( dev-libs/openssl:0[static-libs] )"
+
+src_prepare() {
+ sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+
+ if ! use static ; then
+ sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
+ fi
+
+ # Fix for musl
+ epatch "${FILESDIR}"/${P}-missing-stdint.patch
+
+ emake clean
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto"
+}
+
+src_install() {
+ dobin chntpw cpnt reged
+
+ if use static; then
+ dobin {chntpw,reged}.static
+ fi
+
+ dodoc {HISTORY,README,regedit,WinReg}.txt
+}
diff --git a/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch b/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch
new file mode 100644
index 00000000..e6b49028
--- /dev/null
+++ b/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch
@@ -0,0 +1,11 @@
+diff -Naur chntpw-140201.orig/ntreg.h chntpw-140201/ntreg.h
+--- chntpw-140201.orig/ntreg.h 2014-02-01 08:54:37.000000000 -0800
++++ chntpw-140201/ntreg.h 2016-03-02 18:26:33.820980981 -0800
+@@ -24,6 +24,7 @@
+
+ #ifndef _INCLUDE_NTREG_H
+ #define _INCLUDE_NTREG_H 1
++#include <stdint.h>
+
+ #define SZ_MAX 4096 /* Max unicode strlen before we truncate */
+
diff --git a/app-crypt/chntpw/metadata.xml b/app-crypt/chntpw/metadata.xml
new file mode 100644
index 00000000..040cba5f
--- /dev/null
+++ b/app-crypt/chntpw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+</pkgmetadata>