aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-04-03 05:21:56 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-04-03 05:21:56 -0400
commit0527f42381821c3b999eb8ee84c7148a80e0ac7d (patch)
tree18612b844411339aa0327236f9e47cde1c8798f3 /dev-util
parentUpdate README (diff)
downloadmusl-0527f42381821c3b999eb8ee84c7148a80e0ac7d.tar.gz
musl-0527f42381821c3b999eb8ee84c7148a80e0ac7d.tar.bz2
musl-0527f42381821c3b999eb8ee84c7148a80e0ac7d.zip
dev-util/strace: prepare 4.11 for musl
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/Manifest3
-rw-r--r--dev-util/strace/metadata.xml19
-rw-r--r--dev-util/strace/strace-4.11-r99.ebuild58
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
new file mode 100644
index 00000000..83d6db17
--- /dev/null
+++ b/dev-util/strace/Manifest
@@ -0,0 +1,3 @@
+DIST strace-4.11.tar.xz 679924 SHA256 e86a5f6cd8f941f67f3e4b28f4e60f3d9185c951cf266404533210a2e5cd8152 SHA512 e1e07ed427f504f53bcd117b61bb96a780b0f531010856ed157e4d8c2090371bf320ab59a02b88e67bf2afd443fba67e12f90e53afeab795188c89c6496daecd WHIRLPOOL eee2ae13670dc6f52c45e8275e54655216bd63f1bba2b056a31cb2ee1431f3f15060112a4807eb552a36429bee5d358a5ac3290d25f8875ffd818bb6fcb21a2f
+EBUILD strace-4.11-r99.ebuild 1533 SHA256 095e6eeb5f030a06458781f42f856d4188f995051df3886fd79c9386388df481 SHA512 02e867ee26a0f5b5b85dfb32d9166549b81b9332f52b3b6dc6ae3ff51aed5d5fe39ee91cadc090f06178f45de5390cf0a60a1ed3446cab2e591bb40e5653e991 WHIRLPOOL b24c5a5d32d397848ac9e39d7f387fbd6df5365c6117c60269a49886394a798d9aa27b21956ab7cf7745c418d1370e7bbd5054bdbbac292620fce1d93a9c6edd
+MISC metadata.xml 593 SHA256 e109b90d149d7f0a92316f83f9695c40f2d702625c274b3a9c48bfab2b38dd53 SHA512 67300cfcaba830a47e49cd327bf2d8490b084b016a321fd6e19e52d8dc28968395b3ffc114675a7d4dc723a9ddd7b57c3ede10207a226d60a2225f88aceb59e4 WHIRLPOOL 1af581a8525b849b93b4e2f1c7106fb4805c61818d374e451b5cdf88d7e0d87a41e5175d08e789daab6daf4832ed4b055e9b7de4ad7516220c9da0c203bdc910
diff --git a/dev-util/strace/metadata.xml b/dev-util/strace/metadata.xml
new file mode 100644
index 00000000..869980f0
--- /dev/null
+++ b/dev-util/strace/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <use>
+ <flag name="aio">
+ Enable <pkg>dev-libs/libaio</pkg> support for tracing Asynchronous I/O operations
+ </flag>
+ <flag name="unwind">
+ Enable stack backtraces (-k flag) via <pkg>sys-libs/libunwind</pkg>
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">strace</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/strace/strace-4.11-r99.ebuild b/dev-util/strace/strace-4.11-r99.ebuild
new file mode 100644
index 00000000..b99f823e
--- /dev/null
+++ b/dev-util/strace/strace-4.11-r99.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://strace.git.sourceforge.net/gitroot/strace/strace"
+ inherit git-2 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio perl static unwind"
+
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
+# strace only uses the header from libaio to decode structs
+DEPEND="static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ if epatch_user || [[ ! -e configure ]] ; then
+ # git generation
+ ./xlat/gen.sh
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ export ac_cv_header_libaio_h=$(usex aio)
+ export ac_cv_header_stdc=no
+
+ # Stub out the -k test since it's known to be flaky. #545812
+ sed -i '1iexit 77' tests*/strace-k.test || die
+}
+
+src_configure() {
+ econf $(use_with unwind libunwind)
+}
+
+src_install() {
+ default
+ use perl || rm "${ED}"/usr/bin/strace-graph
+ dodoc CREDITS
+}