aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2018-06-19 13:52:15 -0700
committerAric Belsito <lluixhi@gmail.com>2018-06-19 13:52:15 -0700
commit947ad5dadfbd82660ad76713c3837e57a9dc0fb8 (patch)
treecb1faecfa448aee16fe2e847d7b143798b724fe5 /dev-util
parentdev-util/cargo: version bump to 0.27.0 (diff)
downloadmusl-947ad5dadfbd82660ad76713c3837e57a9dc0fb8.tar.gz
musl-947ad5dadfbd82660ad76713c3837e57a9dc0fb8.tar.bz2
musl-947ad5dadfbd82660ad76713c3837e57a9dc0fb8.zip
dev-util/cargo: add libressl patches
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cargo/cargo-0.26.0.ebuild8
-rw-r--r--dev-util/cargo/cargo-0.27.0.ebuild8
-rw-r--r--dev-util/cargo/files/cargo26-libressl27.patch24
-rw-r--r--dev-util/cargo/files/cargo27-libressl27.patch24
4 files changed, 62 insertions, 2 deletions
diff --git a/dev-util/cargo/cargo-0.26.0.ebuild b/dev-util/cargo/cargo-0.26.0.ebuild
index d1ce4ed4..bb5b2813 100644
--- a/dev-util/cargo/cargo-0.26.0.ebuild
+++ b/dev-util/cargo/cargo-0.26.0.ebuild
@@ -136,7 +136,7 @@ winapi-i686-pc-windows-gnu-0.4.0
winapi-x86_64-pc-windows-gnu-0.4.0
wincolor-0.1.6"
-inherit bash-completion-r1 cargo versionator
+inherit bash-completion-r1 cargo epatch versionator
case "${CHOST}" in
armv7a*)
@@ -214,6 +214,12 @@ DEPEND="
PATCHES=()
+src_prepare() {
+ default
+
+ (cd ${WORKDIR} && epatch "${FILESDIR}/cargo26-libressl27.patch" || die "Could not apply patch")
+}
+
src_configure() {
# Do nothing
echo "Configuring cargo..."
diff --git a/dev-util/cargo/cargo-0.27.0.ebuild b/dev-util/cargo/cargo-0.27.0.ebuild
index c31d5914..60a5d5f6 100644
--- a/dev-util/cargo/cargo-0.27.0.ebuild
+++ b/dev-util/cargo/cargo-0.27.0.ebuild
@@ -124,7 +124,7 @@ winapi-i686-pc-windows-gnu-0.4.0
winapi-x86_64-pc-windows-gnu-0.4.0
wincolor-0.1.6"
-inherit bash-completion-r1 cargo versionator
+inherit bash-completion-r1 cargo epatch versionator
case "${CHOST}" in
armv7a*)
@@ -202,6 +202,12 @@ DEPEND="
PATCHES=()
+src_prepare() {
+ default
+
+ (cd ${WORKDIR} && epatch "${FILESDIR}/cargo27-libressl27.patch" || die "Could not apply patch")
+}
+
src_configure() {
# Do nothing
echo "Configuring cargo..."
diff --git a/dev-util/cargo/files/cargo26-libressl27.patch b/dev-util/cargo/files/cargo26-libressl27.patch
new file mode 100644
index 00000000..17dfb0b0
--- /dev/null
+++ b/dev-util/cargo/files/cargo26-libressl27.patch
@@ -0,0 +1,24 @@
+--- a/cargo_home/gentoo/libgit2-sys/libgit2/src/openssl_stream.c 2018-05-07 18:50:07 UTC
++++ b/cargo_home/gentoo/libgit2-sys/libgit2/src/openssl_stream.c
+@@ -104,7 +104,8 @@ int git_openssl_stream_global_init(void)
+ ssl_opts |= SSL_OP_NO_COMPRESSION;
+ #endif
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || \
++ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
+ SSL_load_error_strings();
+ OpenSSL_add_ssl_algorithms();
+ #else
+--- a/cargo_home/gentoo/libgit2-sys/libgit2/src/openssl_stream.h 2018-05-07 18:50:07 UTC
++++ b/cargo_home/gentoo/libgit2-sys/libgit2/src/openssl_stream.h
+@@ -31,7 +31,8 @@ extern int git_openssl__set_cert_location(const char *
+
+
+
+-# if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++# if OPENSSL_VERSION_NUMBER < 0x10100000L || \
++ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
+
+ GIT_INLINE(BIO_METHOD*) BIO_meth_new(int type, const char *name)
+ {
diff --git a/dev-util/cargo/files/cargo27-libressl27.patch b/dev-util/cargo/files/cargo27-libressl27.patch
new file mode 100644
index 00000000..546f38c7
--- /dev/null
+++ b/dev-util/cargo/files/cargo27-libressl27.patch
@@ -0,0 +1,24 @@
+--- a/cargo_home/gentoo/libgit2-sys/libgit2/src/streams/openssl.c 2018-05-07 18:50:07 UTC
++++ b/cargo_home/gentoo/libgit2-sys/libgit2/src/streams/openssl.c
+@@ -104,7 +104,8 @@ int git_openssl_stream_global_init(void)
+ ssl_opts |= SSL_OP_NO_COMPRESSION;
+ #endif
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || \
++ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
+ SSL_load_error_strings();
+ OpenSSL_add_ssl_algorithms();
+ #else
+--- a/cargo_home/gentoo/libgit2-sys/libgit2/src/streams/openssl.h 2018-05-07 18:50:07 UTC
++++ b/cargo_home/gentoo/libgit2-sys/libgit2/src/streams/openssl.h
+@@ -31,7 +31,8 @@ extern int git_openssl__set_cert_location(const char *
+
+
+
+-# if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++# if OPENSSL_VERSION_NUMBER < 0x10100000L || \
++ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
+
+ GIT_INLINE(BIO_METHOD*) BIO_meth_new(int type, const char *name)
+ {