aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2018-01-24 13:24:50 -0800
committerAric Belsito <lluixhi@gmail.com>2018-01-24 13:24:50 -0800
commit8cb070d72b53b42298e2652bbe85343412775266 (patch)
treedd23490f2a4500b43577fd40bd6323737e38d354 /media-libs
parentMerge remote-tracking branch 'github/pr/87' (diff)
downloadmusl-8cb070d72b53b42298e2652bbe85343412775266.tar.gz
musl-8cb070d72b53b42298e2652bbe85343412775266.tar.bz2
musl-8cb070d72b53b42298e2652bbe85343412775266.zip
media-libs/mesa: bump pthread patch
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/files/mesa-18-musl-pthread.patch40
-rw-r--r--media-libs/mesa/mesa-18.0.0_rc2.ebuild2
2 files changed, 41 insertions, 1 deletions
diff --git a/media-libs/mesa/files/mesa-18-musl-pthread.patch b/media-libs/mesa/files/mesa-18-musl-pthread.patch
new file mode 100644
index 00000000..2db16679
--- /dev/null
+++ b/media-libs/mesa/files/mesa-18-musl-pthread.patch
@@ -0,0 +1,40 @@
+diff -Naur mesa-18.0.0-rc2.orig/src/gallium/state_trackers/nine/nine_debug.c mesa-18.0.0-rc2/src/gallium/state_trackers/nine/nine_debug.c
+--- mesa-18.0.0-rc2.orig/src/gallium/state_trackers/nine/nine_debug.c 2018-01-24 13:20:13.287944874 -0800
++++ mesa-18.0.0-rc2/src/gallium/state_trackers/nine/nine_debug.c 2018-01-24 13:23:34.722941267 -0800
+@@ -73,8 +73,8 @@
+ }
+
+ #if defined(HAVE_PTHREAD)
+-# if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
+- (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12))
++# if defined(__linux__) && !(defined(__GLIBC__) || \
++ (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
+ if (dbg_flags & DBG_TID)
+ tid = pthread_self();
+ # endif
+diff -Naur mesa-18.0.0-rc2.orig/src/util/u_thread.h mesa-18.0.0-rc2/src/util/u_thread.h
+--- mesa-18.0.0-rc2.orig/src/util/u_thread.h 2018-01-24 13:20:13.166944876 -0800
++++ mesa-18.0.0-rc2/src/util/u_thread.h 2018-01-24 13:24:11.028940616 -0800
+@@ -61,9 +61,8 @@
+ static inline void u_thread_setname( const char *name )
+ {
+ #if defined(HAVE_PTHREAD)
+-# if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
+- (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12)) && \
+- defined(__linux__)
++# if defined(__linux__) && !(defined(__GLIBC__) || \
++ (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
+ pthread_setname_np(pthread_self(), name);
+ # endif
+ #endif
+@@ -93,8 +92,8 @@
+ static inline bool u_thread_is_self(thrd_t thread)
+ {
+ #if defined(HAVE_PTHREAD)
+-# if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
+- (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12))
++# if defined(__linux__) && !(defined(__GLIBC__) || \
++ (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
+ return pthread_equal(pthread_self(), thread);
+ # endif
+ #endif
diff --git a/media-libs/mesa/mesa-18.0.0_rc2.ebuild b/media-libs/mesa/mesa-18.0.0_rc2.ebuild
index a7bad53d..4d4f5177 100644
--- a/media-libs/mesa/mesa-18.0.0_rc2.ebuild
+++ b/media-libs/mesa/mesa-18.0.0_rc2.ebuild
@@ -285,7 +285,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-17-execinfo.patch
eapply "${FILESDIR}"/${PN}-17-musl-string_h.patch
eapply "${FILESDIR}"/${PN}-17-musl-invocation_name.patch
- eapply "${FILESDIR}"/${PN}-17-musl-pthread.patch
+ eapply "${FILESDIR}"/${PN}-18-musl-pthread.patch
eautoreconf