aboutsummaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-06-11 18:16:08 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-06-11 18:16:08 -0400
commit8eddda8072add075ebf56cf6d288bc1450d6b5f8 (patch)
tree373e2d36142a298a821f6643c097007aa38aa29f /net-fs
downloadmusl-8eddda8072add075ebf56cf6d288bc1450d6b5f8.tar.gz
musl-8eddda8072add075ebf56cf6d288bc1450d6b5f8.tar.bz2
musl-8eddda8072add075ebf56cf6d288bc1450d6b5f8.zip
Initial migration from hardened-dev::musl
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/Manifest5
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.1-r99.ebuild111
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.1-hardcoded-path.patch44
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.1-paths.h.patch10
-rw-r--r--net-fs/cifs-utils/metadata.xml16
5 files changed, 186 insertions, 0 deletions
diff --git a/net-fs/cifs-utils/Manifest b/net-fs/cifs-utils/Manifest
new file mode 100644
index 00000000..93b81f89
--- /dev/null
+++ b/net-fs/cifs-utils/Manifest
@@ -0,0 +1,5 @@
+AUX cifs-utils-6.1-hardcoded-path.patch 1513 SHA256 2a0415b1452f3033c8322ed102b9acafbab9640f936254002d1bc493a0e6d7d5 SHA512 3ad0fbea11cd6a4bf6072e1131ccf87b0b81a9c869e2ee199f655ebc974c5e79f87694aa162ce2911767b6689f3b7530895b835d920575b5c37ac8fcd8cf4aad WHIRLPOOL 8684a3a3de491f9bc17070c8ad9d53bad14f5af62692e805bdd548bd4ad731096c01ce580b9800b053fcf583ee7af4166cfe00761f207934fa75b0223b22da76
+AUX cifs-utils-6.1-paths.h.patch 200 SHA256 3998b247b3a2658a637755db8ebf800eee75b3650ca0e114513e5a68fe71939f SHA512 8728a3a7ccc5837faac7e0380c32f8855e71013b6175117f22b1acfdd321363ab7529141e5f3d3e75a60fd0366adc3e23b8b59672fada77e201261d8bcb45ee3 WHIRLPOOL 4a99f745e65632cbbbc4d4c28028bf81fcb5f57076f46a93f1a53143c640007b08f59addbbb062807b2992350137ee54914b75f9e045596fcb0da1f879ca87ad
+DIST cifs-utils-6.1.tar.bz2 390958 SHA256 381f1e9caccdafdcdb0efa32a4cceb77c1a96b0b58702394e4b86dac4825f3b5 SHA512 6427b74edbf56b865dee38a610c74ac5483cdc13096082cfc1e9d225a048c9b5ee0c7afb30e625a615a0e8e9f3767e33765220e27148e2c2a29d12d4129b01fd WHIRLPOOL a800a02a0729996035a331b460cb28ae5463ddecaf205d88173dc08efd7a2bee577995ebba97b36977858c8435ac3b7ec9c7ce5d193f8b30d0602f9546fed5b1
+EBUILD cifs-utils-6.1-r99.ebuild 3101 SHA256 f89c643b1ce05f74e434fd93d54126cba7048c6ea08c8f2a15532b667fecf75e SHA512 32e4fdb22f91a6df7f11fe749ca40cadb731d797eb13f2721b7b6e084f135302973e6a62969b4dc1f3e9c892c47d2a1bd8379c4015730792c8909f438ade8e71 WHIRLPOOL 785d23e8506c333e4cb9bb621e2f619bd22925468b23f4223b9b41adc9bd7d1f268ef0868421796900a62938e3743b6db74acaea52356e71d3d17e349affd111
+MISC metadata.xml 894 SHA256 8d598e43e3e8ffcdca076aeecc8d7748574b9b10b0edcb7f29870c5765dac849 SHA512 351c7e517aeaac819858716a196364f033aa384d70dd8128a2e92d4b300ea451416cace7bcb8feeeffeb57264042d02fd814be3fdc8fc305b86f57e51158724f WHIRLPOOL ae8a5e246350bf67577855da35d3d100bd0485f4885cb2f46ca7a0ec3cc3eb6020a188bb0d08793f231adfd7c0b2fef6fe66d5c61a009a6c3aa4989df35d1299
diff --git a/net-fs/cifs-utils/cifs-utils-6.1-r99.ebuild b/net-fs/cifs-utils/cifs-utils-6.1-r99.ebuild
new file mode 100644
index 00000000..de04aac4
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-6.1-r99.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-6.1-r1.ebuild,v 1.13 2014/06/22 21:28:55 klausman Exp $
+
+EAPI=5
+
+inherit eutils linux-info multilib
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="http://wiki.samba.org/index.php/LinuxCIFS_utils"
+SRC_URI="ftp://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc x86"
+IUSE="+acl +ads +caps +caps-ng creds"
+
+DEPEND="!net-fs/mount-cifs
+ !<net-fs/samba-3.6_rc1
+ ads? (
+ sys-apps/keyutils
+ sys-libs/talloc
+ virtual/krb5
+ )
+ caps? ( !caps-ng? ( sys-libs/libcap ) )
+ caps? ( caps-ng? ( sys-libs/libcap-ng ) )
+ creds? ( sys-apps/keyutils )"
+PDEPEND="${DEPEND}
+ acl? ( || (
+ =net-fs/samba-3.6*[winbind]
+ >=net-fs/samba-4.0.0_alpha1
+ ) )
+"
+
+REQUIRED_USE="acl? ( ads )"
+
+DOCS="doc/linux-cifs-client-guide.odt"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_prepare() {
+ # Do not rely on hardcoded path to systemd-ask-password, bug #478538
+ epatch "${FILESDIR}/${P}-hardcoded-path.patch"
+ epatch "${FILESDIR}/${P}-paths.h.patch" #for musl
+}
+
+src_configure() {
+ ROOTSBINDIR="${EPREFIX}"/sbin \
+ econf \
+ $(use_enable acl cifsacl cifsidmap) \
+ $(use_enable ads cifsupcall) \
+ $(use caps && use_with !caps-ng libcap || echo --without-libcap) \
+ $(use caps && use_with caps-ng libcap-ng || echo --without-libcap-ng) \
+ $(use_enable creds cifscreds)
+}
+
+src_install() {
+ default
+
+ # remove empty directories
+ find "${ED}" -type d -print0 | xargs --null rmdir \
+ --ignore-fail-on-non-empty &>/dev/null
+
+ if use acl ; then
+ dodir /etc/cifs-utils
+ dosym /usr/$(get_libdir)/cifs-utils/idmapwb.so \
+ /etc/cifs-utils/idmap-plugin
+ dodir /etc/request-key.d
+ echo 'create cifs.idmap * * /usr/sbin/cifs.idmap %k' \
+ > "${ED}/etc/request-key.d/cifs.idmap.conf"
+ fi
+
+ if use ads ; then
+ dodir /etc/request-key.d
+ echo 'create dns_resolver * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.upcall.conf"
+ fi
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use acl ; then
+ einfo "The cifs.idmap utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.idmap.conf"
+ einfo "This enables you to get and set CIFS acls."
+ fi
+
+ if use ads ; then
+ einfo "The cifs.upcall utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.upcall.conf"
+ einfo "This enables you to mount DFS shares."
+ fi
+}
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.1-hardcoded-path.patch b/net-fs/cifs-utils/files/cifs-utils-6.1-hardcoded-path.patch
new file mode 100644
index 00000000..c2e2ea21
--- /dev/null
+++ b/net-fs/cifs-utils/files/cifs-utils-6.1-hardcoded-path.patch
@@ -0,0 +1,44 @@
+From 4e315f6a02a4edb259b33bcf0665eba259fee2f2 Mon Sep 17 00:00:00 2001
+From: =?utf8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 30 Jul 2013 10:00:26 +0200
+Subject: [PATCH] Do not rely on hardcoded path to systemd-ask-password.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=utf8
+Content-Transfer-Encoding: 8bit
+
+Relying on hardcoded /bin/systemd-ask-password path breaks systemd that
+install systemd-ask-password in /usr/bin. Since both paths are supposed
+to be in ${PATH} and popen() passes the command to shell, just pass
+'systemd-ask-password' and let the shell find it.
+
+Fixes: https://bugzilla.samba.org/show_bug.cgi?id=10054
+Signed-off-by: Michał Górny <mgorny@gentoo.org>
+---
+ mount.cifs.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/mount.cifs.c b/mount.cifs.c
+index e76beee..7206dcb 100644
+--- a/mount.cifs.c
++++ b/mount.cifs.c
+@@ -1626,7 +1626,7 @@ drop_child_privs(void)
+ }
+
+ /*
+- * If systemd is running and /bin/systemd-ask-password --
++ * If systemd is running and systemd-ask-password --
+ * is available, then use that else fallback on getpass(..)
+ *
+ * Returns: @input or NULL on error
+@@ -1649,7 +1649,7 @@ get_password(const char *prompt, char *input, int capacity)
+ FILE *ask_pass_fp = NULL;
+
+ cmd = ret = NULL;
+- if (asprintf(&cmd, "/bin/systemd-ask-password \"%s\"", prompt) >= 0) {
++ if (asprintf(&cmd, "systemd-ask-password \"%s\"", prompt) >= 0) {
+ ask_pass_fp = popen (cmd, "re");
+ free (cmd);
+ }
+--
+1.7.0.4
+
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.1-paths.h.patch b/net-fs/cifs-utils/files/cifs-utils-6.1-paths.h.patch
new file mode 100644
index 00000000..5e2434d7
--- /dev/null
+++ b/net-fs/cifs-utils/files/cifs-utils-6.1-paths.h.patch
@@ -0,0 +1,10 @@
+--- a/cifs-utils-6.1/mtab.c
++++ b/cifs-utils-6.1/mtab.c
+@@ -38,6 +38,7 @@
+ #include <mntent.h>
+ #include <stdlib.h>
+ #include <signal.h>
++#include <paths.h>
+ #include "mount.h"
+ #include "config.h"
+
diff --git a/net-fs/cifs-utils/metadata.xml b/net-fs/cifs-utils/metadata.xml
new file mode 100644
index 00000000..a31a339f
--- /dev/null
+++ b/net-fs/cifs-utils/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>samba</herd>
+ <maintainer>
+ <email>samba@gentoo.org</email>
+ <name>Samba Team</name>
+ </maintainer>
+ <longdescription>The in-kernel CIFS filesystem relies on a set of user-space tools. That package of tools is called cifs-utils. Although not really part of Samba proper, these tools were originally part of the Samba package. For several reasons, shipping these tools as part of Samba was problematic and it was deemed better to split them off into their own package</longdescription>
+ <use>
+ <flag name="ads">Enable Active Directory support and create cifs.idmap binary - idmap support</flag>
+ <flag name="caps">libcap support</flag>
+ <flag name="caps-ng">libcap-ng support</flag>
+ <flag name="creds">cifs credentials support</flag>
+ </use>
+</pkgmetadata>