aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjorn Pagen <bjornpagen@gmail.com>2017-10-31 20:04:01 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-11-01 21:19:51 -0400
commit1c0278510e8dcd758d30a6b70655a9d065b690d9 (patch)
treefb19f71562aec6043fe36ded5da4e3d31a2ecc2b /sys-auth
parentadd net-libs/libqmi (diff)
downloadmusl-1c0278510e8dcd758d30a6b70655a9d065b690d9.tar.gz
musl-1c0278510e8dcd758d30a6b70655a9d065b690d9.tar.bz2
musl-1c0278510e8dcd758d30a6b70655a9d065b690d9.zip
added sys-auth/elogind
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/elogind/Manifest4
-rw-r--r--sys-auth/elogind/elogind-234.4.ebuild106
-rw-r--r--sys-auth/elogind/files/elogind-226.4-docs.patch15
-rw-r--r--sys-auth/elogind/files/elogind-fix-musl.patch38
4 files changed, 163 insertions, 0 deletions
diff --git a/sys-auth/elogind/Manifest b/sys-auth/elogind/Manifest
new file mode 100644
index 00000000..a1dd5104
--- /dev/null
+++ b/sys-auth/elogind/Manifest
@@ -0,0 +1,4 @@
+AUX elogind-226.4-docs.patch 355 SHA256 4fa3a1aa38a9ba23cd023a3ace11c4c8155ee856a6cd7f228ac65cd921629b24 SHA512 dc942f190ea2064e194808db7c6ede618d536778f1b574658ddb9c0aa4a106f6129cc18000eaa63aeca1b16ad28fe5f5dbee441bd93436ae62eb4740236f94ae WHIRLPOOL 45bdbbaa103b6bf94a0e3544978eb1ea0a942162711227f8c9c17f1c606d15d1e1e44f898635b26c80bf96d662c612daf59aed007aa57744baed574b20861a38
+AUX elogind-fix-musl.patch 934 SHA256 f1e62001228991fab4b5f3703cbb31933d749010c5ef8c3321d14b0032422b53 SHA512 3d07799d6e13c1c5499e9079d4b35141e3deac0d9bf23c5a999687e233de774c0cfa41d3ecbf0b41950672b443cf6e17a9b3e46f7ef495683af04d34b7c2e49b WHIRLPOOL 922eb5dcf1e0de1a80359e7bb6890ec5f646ab59f6b3cadbc6a8f51cd5256ef6bb2c876d519fae1664c1851017e6a5803e0162372340d3da0149f9931fbfa06a
+DIST elogind-234.4.tar.gz 973370 SHA256 ffb465a62c4281c19b07eb7fbb9ad0987f3b726ae1a868a92a3144d7714542f3 SHA512 2df4fa318074d4f5e5dbba353cf817068a2703ffed40cdeae4cba2dea4ee143d1c5fc076b19419f1c4299392088c2c14b430d8aa1ded03b62117311802305d5e WHIRLPOOL 1b735338cb02ef8cffb5837a0702110117ae1d677a4cbf106180c549485f7fb0604f3134e6ff5e14b23485ddfe4d4415a41e69d93b8f099cee41a220d0ea4a69
+EBUILD elogind-234.4.ebuild 2858 SHA256 d29413423f2f3b3e7eb5cf7b0171eda8e5a3e12d37af0ac0193e8669a5a47cf6 SHA512 3a5f1f51da798b6954619ddc50f5a32ef2bc8a82610f6b5d6e62813e2f673fb322a7dd89a231f00429f4ef0b142a1244df6d622922efb1a0f6802a9e1bad6caf WHIRLPOOL 254ec63617f1115e538947a123543f7382b4684879779fa43c524f0b7a15fb2c6db4335a81a4e364573401a33f9f8412d156813a601f632fa6b763fea5155436
diff --git a/sys-auth/elogind/elogind-234.4.ebuild b/sys-auth/elogind/elogind-234.4.ebuild
new file mode 100644
index 00000000..51251628
--- /dev/null
+++ b/sys-auth/elogind/elogind-234.4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info pam udev
+
+DESCRIPTION="The systemd project's logind, extracted to a standalone package"
+HOMEPAGE="https://github.com/elogind/elogind"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl debug pam policykit selinux"
+
+RDEPEND="
+ sys-apps/util-linux
+ sys-libs/libcap
+ virtual/libudev:=
+ acl? ( sys-apps/acl )
+ pam? ( virtual/pam )
+ selinux? ( sys-libs/libselinux )
+ !sys-apps/systemd
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-util/gperf
+ dev-util/intltool
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+PDEPEND="
+ sys-apps/dbus
+ policykit? ( sys-auth/polkit )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-226.4-docs.patch" )
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SECURITY_SMACK
+ ~SIGNALFD ~TIMERFD"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${PN}-fix-musl.patch"
+ eautoreconf # Makefile.am patched by "${FILESDIR}/${P}-docs.patch"
+}
+
+src_configure() {
+ econf \
+ --with-pamlibdir=$(getpam_mod_dir) \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --with-rootlibdir="${EPREFIX}"/$(get_libdir) \
+ --with-rootprefix="${EPREFIX}/" \
+ --with-rootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind \
+ --enable-smack \
+ --with-cgroup-controller=openrc \
+ --disable-lto \
+ $(use_enable debug debug elogind) \
+ $(use_enable acl) \
+ $(use_enable pam) \
+ $(use_enable selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if [ "$(rc-config list boot | grep elogind)" != "" ]; then
+ ewarn "elogind is currently started from boot runlevel."
+ elif [ "$(rc-config list default | grep elogind)" != "" ]; then
+ ewarn "elogind is currently started from default runlevel."
+ ewarn "Please remove elogind from the default runlevel and"
+ ewarn "add it to the boot runlevel by:"
+ ewarn "# rc-update del elogind default"
+ ewarn "# rc-update add elogind boot"
+ else
+ ewarn "elogind is currently not started from any runlevel."
+ ewarn "You may add it to the boot runlevel by:"
+ ewarn "# rc-update add elogind boot"
+ fi
+ ewarn "Alternatively you can leave elogind out of any"
+ ewarn "runlevel. It will then be started automatically"
+ if use pam; then
+ ewarn "when the first service calls it via dbus, or the"
+ ewarn "first user logs into the system."
+ else
+ ewarn "when the first service calls it via dbus."
+ fi
+}
diff --git a/sys-auth/elogind/files/elogind-226.4-docs.patch b/sys-auth/elogind/files/elogind-226.4-docs.patch
new file mode 100644
index 00000000..4161f633
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-226.4-docs.patch
@@ -0,0 +1,15 @@
+--- a/Makefile.am 2017-02-16 13:22:56.764985896 +0100
++++ b/Makefile.am 2017-02-16 13:23:04.998986057 +0100
+@@ -194,12 +194,6 @@
+ bin_PROGRAMS =
+ rootlibexec_PROGRAMS =
+
+-dist_doc_DATA = \
+- README \
+- NEWS \
+- LICENSE.LGPL2.1 \
+- LICENSE.GPL2
+-
+ @INTLTOOL_POLICY_RULE@
+
+ # ------------------------------------------------------------------------------
diff --git a/sys-auth/elogind/files/elogind-fix-musl.patch b/sys-auth/elogind/files/elogind-fix-musl.patch
new file mode 100644
index 00000000..4aba103d
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-fix-musl.patch
@@ -0,0 +1,38 @@
+--- a/src/test/test-hexdecoct.c
++++ b/src/test/test-hexdecoct.c
+@@ -22,6 +22,16 @@
+ #include "macro.h"
+ #include "string-util.h"
+
++#define strndupa(s, n) \
++ ({ \
++ const char *__in = (s); \
++ size_t __len = strnlen(__in, (n)); \
++ char *__out = (char *)alloca(__len + 1); \
++ __out[__len] = '\0'; \
++ (char *)memcpy(__out, __in, __len); \
++ })
++
++
+ static void test_hexchar(void) {
+ assert_se(hexchar(0xa) == 'a');
+ assert_se(hexchar(0x0) == '0');
+--- a/src/test/test-sizeof.c
++++ b/src/test/test-sizeof.c
+@@ -48,8 +48,6 @@
+ info(unsigned);
+ info(long unsigned);
+ info(long long unsigned);
+- info(__syscall_ulong_t);
+- info(__syscall_slong_t);
+
+ info(float);
+ info(double);
+@@ -59,7 +57,6 @@
+ info(ssize_t);
+ info(time_t);
+ info(usec_t);
+- info(__time_t);
+
+ info(enum Enum);
+ info(enum BigEnum);