aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/lilo/lilo-24.1.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/sys-boot/lilo/lilo-24.1.ebuild b/sys-boot/lilo/lilo-24.1.ebuild
index be00f6df..981a24da 100644
--- a/sys-boot/lilo/lilo-24.1.ebuild
+++ b/sys-boot/lilo/lilo-24.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -53,10 +53,6 @@ src_compile() {
# lilo needs this. bug #140209
export LC_ALL=C
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS=$(test-flags-CC -fno-pic -nopie)
-
# we explicitly prevent the custom CFLAGS for stability reasons
if use static; then
local target=alles
@@ -64,7 +60,7 @@ src_compile() {
local target=all
fi
- emake CC="$(tc-getCC) ${LDFLAGS} ${HARDENED_CFLAGS}" ${target} || die
+ emake CC="$(tc-getCC) ${LDFLAGS}" ${target} || die
}
src_install() {