aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-07-21 18:40:27 +0200
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-07-21 18:40:27 +0200
commitc3217660fc2bbab18e907a28982b476aa66f9261 (patch)
tree26f4d292b074f600aa7b4a1d23bd1f70a9d97ee9 /Makefile
parentMake sure gnome-keyring is always ran after system-auth has completed. (diff)
downloadpambase-c3217660fc2bbab18e907a28982b476aa66f9261.tar.gz
pambase-c3217660fc2bbab18e907a28982b476aa66f9261.tar.bz2
pambase-c3217660fc2bbab18e907a28982b476aa66f9261.zip
Add support for pam_ssh module.
The pam_ssh module allows you to type in your SSH key passphrase to login in the system, and also spawns an ssh-agent that has the passphrase cached in.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 13398ff..651b641 100644
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,10 @@ ifeq "$(MKTEMP)" "yes"
PAMFLAGS += -DHAVE_MKTEMP=1
endif
+ifeq "$(PAM_SSH)" "yes"
+PAMFLAGS += -DHAVE_PAM_SSH=1
+endif
+
ifeq "$(DEBUG)" "yes"
PAMFLAGS += -DDEBUG=debug
endif