summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-01-29 19:07:38 +0000
committerZac Medico <zmedico@gentoo.org>2010-01-29 19:07:38 +0000
commit942bd37e130610672e46877fa333636f12a30bc6 (patch)
tree91ca9e61de67a05faed4622022acd4e182e74922 /bin
parentRemove code for svn.IO_error and bzr.IO_error categories since they don't (diff)
downloadportage-idfetch-942bd37e130610672e46877fa333636f12a30bc6.tar.gz
portage-idfetch-942bd37e130610672e46877fa333636f12a30bc6.tar.bz2
portage-idfetch-942bd37e130610672e46877fa333636f12a30bc6.zip
Don't ignore CVS/Entries.IO_error when not in commit mode.
svn path=/main/trunk/; revision=15272
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman11
1 files changed, 5 insertions, 6 deletions
diff --git a/bin/repoman b/bin/repoman
index 193cc1e8..95a44f0f 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1157,12 +1157,11 @@ for x in scanlist:
if l[-7:] == ".ebuild":
eadded.append(os.path.basename(l[:-7]))
except IOError:
- if options.mode == 'commit':
- if vcs == "cvs":
- stats["CVS/Entries.IO_error"] += 1
- fails["CVS/Entries.IO_error"].append(checkdir+"/CVS/Entries")
- else:
- raise
+ if vcs == "cvs":
+ stats["CVS/Entries.IO_error"] += 1
+ fails["CVS/Entries.IO_error"].append(checkdir+"/CVS/Entries")
+ else:
+ raise
continue
mf = Manifest(checkdir, repoman_settings["DISTDIR"])