summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-07-23 20:40:14 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-07-23 20:40:14 +0000
commitfa229257b870d3544cca40671cb82aea570285f6 (patch)
tree906e10124b15c768eedce083cc5c87094a2e05b5 /dev-libs/libpqxx/libpqxx-2.6.7.ebuild
parentdev-db/pgadmin3: Version bump to 1.4.3 (diff)
downloadtesting-fa229257b870d3544cca40671cb82aea570285f6.tar.gz
testing-fa229257b870d3544cca40671cb82aea570285f6.tar.bz2
testing-fa229257b870d3544cca40671cb82aea570285f6.zip
dev-libs/libpqxx: Version bump to v2.6.7
SRC_URI and HOMEPAGE updated General ebuild cleanup src_test() added svn path=/testing/; revision=5
Diffstat (limited to 'dev-libs/libpqxx/libpqxx-2.6.7.ebuild')
-rw-r--r--dev-libs/libpqxx/libpqxx-2.6.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libpqxx/libpqxx-2.6.7.ebuild b/dev-libs/libpqxx/libpqxx-2.6.7.ebuild
new file mode 100644
index 0000000..1a4b385
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-2.6.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="C++ client API for PostgreSQL. The standard front-end for writing C++ programs that use PostgreSQL. Supersedes older libpq++ interface."
+SRC_URI="ftp://thaiopensource.org/software/${PN}/${P}.tar.gz"
+HOMEPAGE="http://thaiopensource.org/development/libpqxx/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-db/libpq"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+ dohtml -r doc/html/*
+}
+
+src_test() {
+ ewarn "The tests need a running postgresl server and an existing database!"
+ ewarn "You can set the following environment variables to change the connection parameters:"
+ ewarn "PGDATABASE (default: username, probably root)"
+ ewarn "PGHOST (default: localhost)"
+ ewarn "PGPORT (default: pg's UNIX domain-socket)"
+ ewarn "PGUSER (default: username, probably root)"
+ epause 10
+
+ cd "${S}/test"
+ emake -j check || die "emake check failed"
+}