summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpqxx/libpqxx-2.6.7.ebuild')
-rw-r--r--dev-libs/libpqxx/libpqxx-2.6.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libpqxx/libpqxx-2.6.7.ebuild b/dev-libs/libpqxx/libpqxx-2.6.7.ebuild
new file mode 100644
index 0000000..1a4b385
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-2.6.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="C++ client API for PostgreSQL. The standard front-end for writing C++ programs that use PostgreSQL. Supersedes older libpq++ interface."
+SRC_URI="ftp://thaiopensource.org/software/${PN}/${P}.tar.gz"
+HOMEPAGE="http://thaiopensource.org/development/libpqxx/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-db/libpq"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+ dohtml -r doc/html/*
+}
+
+src_test() {
+ ewarn "The tests need a running postgresl server and an existing database!"
+ ewarn "You can set the following environment variables to change the connection parameters:"
+ ewarn "PGDATABASE (default: username, probably root)"
+ ewarn "PGHOST (default: localhost)"
+ ewarn "PGPORT (default: pg's UNIX domain-socket)"
+ ewarn "PGUSER (default: username, probably root)"
+ epause 10
+
+ cd "${S}/test"
+ emake -j check || die "emake check failed"
+}