aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorleycec <leycec@gmail.com>2017-06-13 01:51:07 -0400
committerDavide Pesavento <pesa@gentoo.org>2017-06-17 03:38:08 +0200
commitc73c5e142b217215f6e4802266d850c8aa0adc9b (patch)
treef259ffe54743dffd520f01cd797003400845e02a
parenttravis: update (diff)
downloadqt-c73c5e142b217215f6e4802266d850c8aa0adc9b.tar.gz
qt-c73c5e142b217215f6e4802266d850c8aa0adc9b.tar.bz2
qt-c73c5e142b217215f6e4802266d850c8aa0adc9b.zip
dev-python/pyside: Fix upstream repo URIs.
The live PySide2 and shiboken2 ebuilds now pull from the same "pyside-setup.git" repository. The old separate "pyside.git" and "shiboken.git" repositories still exist but are no longer maintained. Since upstream has resolved PYSIDE-502, the prior patch for optional dependencies in the live PySide2 ebuild has been removed.
-rw-r--r--dev-python/pyside/pyside-9999.ebuild19
-rw-r--r--dev-python/shiboken/shiboken-9999.ebuild6
2 files changed, 9 insertions, 16 deletions
diff --git a/dev-python/pyside/pyside-9999.ebuild b/dev-python/pyside/pyside-9999.ebuild
index 36134162..0ed4aa4c 100644
--- a/dev-python/pyside/pyside-9999.ebuild
+++ b/dev-python/pyside/pyside-9999.ebuild
@@ -10,8 +10,8 @@ inherit cmake-utils python-r1 virtualx git-r3
DESCRIPTION="Python bindings for the Qt framework"
HOMEPAGE="https://wiki.qt.io/PySide2"
EGIT_REPO_URI=(
- "git://code.qt.io/pyside/${PN}.git"
- "https://code.qt.io/git/pyside/${PN}.git"
+ "git://code.qt.io/pyside/pyside-setup.git"
+ "https://code.qt.io/git/pyside/pyside-setup.git"
)
#FIXME: Switch to the clang-enabled "dev" branch once stable.
EGIT_BRANCH="5.6"
@@ -77,15 +77,9 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-src_prepare() {
- #FIXME: Remove the following "sed" patch after this upstream issue is closed:
- # https://bugreports.qt.io/browse/PYSIDE-502
- # Force the optional "Qt5Concurrent", "Qt5Gui", "Qt5Network",
- # "Qt5PrintSupport", "Qt5Sql", "Qt5Test", and "Qt5Widgets" packages
- # erroneously marked as mandatory to be optional.
- sed -i -e 's/^\(CHECK_PACKAGE_FOUND(Qt5\(Concurrent\|Gui\|Network\|PrintSupport\|Sql\|Test\|Widgets\)\))$/\1 opt)/' \
- PySide2/CMakeLists.txt || die
+S=${WORKDIR}/${P}/sources/pyside2
+src_prepare() {
if use prefix; then
cp "${FILESDIR}"/rpath.cmake . || die
sed -i -e '1iinclude(rpath.cmake)' CMakeLists.txt || die
@@ -95,10 +89,7 @@ src_prepare() {
}
src_configure() {
- # For each line of the form "CHECK_PACKAGE_FOUND(${PACKAGE_NAME} opt)" in
- # PySide2/CMakeLists.txt defining an optional dependency, an option of the
- # form "-DCMAKE_DISABLE_FIND_PACKAGE_${PACKAGE_NAME}=$(usex !${USE_FLAG})"
- # is passed to cmake here conditionally disabling this dependency.
+ # See COLLECT_MODULE_IF_FOUND macros in CMakeLists.txt
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
-DCMAKE_DISABLE_FIND_PACKAGE_Qt5Concurrent=$(usex !concurrent)
diff --git a/dev-python/shiboken/shiboken-9999.ebuild b/dev-python/shiboken/shiboken-9999.ebuild
index 6eb6cdd8..db5f67f6 100644
--- a/dev-python/shiboken/shiboken-9999.ebuild
+++ b/dev-python/shiboken/shiboken-9999.ebuild
@@ -10,8 +10,8 @@ inherit cmake-utils llvm python-r1 git-r3
DESCRIPTION="Tool for creating Python bindings for C++ libraries"
HOMEPAGE="https://wiki.qt.io/PySide2"
EGIT_REPO_URI=(
- "git://code.qt.io/pyside/${PN}.git"
- "https://code.qt.io/git/pyside/${PN}.git"
+ "git://code.qt.io/pyside/pyside-setup.git"
+ "https://code.qt.io/git/pyside/pyside-setup.git"
)
#FIXME: Switch to the clang-enabled "dev" branch once stable.
EGIT_BRANCH="5.6"
@@ -36,6 +36,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+S=${WORKDIR}/${P}/sources/shiboken2
+
DOCS=( AUTHORS )
src_prepare() {