aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-06-08 17:17:21 +0300
committerJimi Huotari <chiitoo@gentoo.org>2022-06-20 21:02:03 +0300
commitd7f1589d6ed6ac7f02af7268df53ac5d9654a71e (patch)
tree7c233dfbba958e76d960b93c0dcbecb18d93e8f7
parentdev-qt/qttools: add a USE-flag for each tool (diff)
downloadqt-d7f1589d6ed6ac7f02af7268df53ac5d9654a71e.tar.gz
qt-d7f1589d6ed6ac7f02af7268df53ac5d9654a71e.tar.bz2
qt-d7f1589d6ed6ac7f02af7268df53ac5d9654a71e.zip
dev-qt/qtbase: depend on USE="gui" if USE="vnc"
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--dev-qt/qtbase/qtbase-6.3.0.ebuild3
-rw-r--r--dev-qt/qtbase/qtbase-6.3.9999.ebuild3
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/dev-qt/qtbase/qtbase-6.3.0.ebuild b/dev-qt/qtbase/qtbase-6.3.0.ebuild
index a8e1f084..36931e0e 100644
--- a/dev-qt/qtbase/qtbase-6.3.0.ebuild
+++ b/dev-qt/qtbase/qtbase-6.3.0.ebuild
@@ -26,7 +26,6 @@ QTSQL_IUSE="freetds mysql oci8 odbc postgres +sqlite"
IUSE+=" ${QTGUI_IUSE} ${QTNETWORK_IUSE} ${QTSQL_IUSE} cups gtk icu systemd +udev"
# QtPrintSupport = QtGui + QtWidgets enabled.
# ibus = xkbcommon + dbus, and xkbcommon needs either libinput or X
-# moved vnc logically to QtNetwork as that is upstream condition for it
REQUIRED_USE+="
$(printf '%s? ( gui ) ' ${QTGUI_IUSE//+/})
$(printf '%s? ( network ) ' ${QTNETWORK_IUSE//+/})
@@ -38,6 +37,7 @@ REQUIRED_USE+="
gui? ( || ( eglfs X ) || ( libinput X ) )
libinput? ( udev )
sql? ( || ( freetds mysql oci8 odbc postgres sqlite ) )
+ vnc? ( gui )
X? ( gles2-only? ( egl ) )
"
@@ -173,5 +173,6 @@ src_configure() {
$(qt_feature sqlite sql_sqlite)
$(qt_feature sqlite system_sqlite)
)
+
qt6-build_src_configure
}
diff --git a/dev-qt/qtbase/qtbase-6.3.9999.ebuild b/dev-qt/qtbase/qtbase-6.3.9999.ebuild
index a8e1f084..36931e0e 100644
--- a/dev-qt/qtbase/qtbase-6.3.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.3.9999.ebuild
@@ -26,7 +26,6 @@ QTSQL_IUSE="freetds mysql oci8 odbc postgres +sqlite"
IUSE+=" ${QTGUI_IUSE} ${QTNETWORK_IUSE} ${QTSQL_IUSE} cups gtk icu systemd +udev"
# QtPrintSupport = QtGui + QtWidgets enabled.
# ibus = xkbcommon + dbus, and xkbcommon needs either libinput or X
-# moved vnc logically to QtNetwork as that is upstream condition for it
REQUIRED_USE+="
$(printf '%s? ( gui ) ' ${QTGUI_IUSE//+/})
$(printf '%s? ( network ) ' ${QTNETWORK_IUSE//+/})
@@ -38,6 +37,7 @@ REQUIRED_USE+="
gui? ( || ( eglfs X ) || ( libinput X ) )
libinput? ( udev )
sql? ( || ( freetds mysql oci8 odbc postgres sqlite ) )
+ vnc? ( gui )
X? ( gles2-only? ( egl ) )
"
@@ -173,5 +173,6 @@ src_configure() {
$(qt_feature sqlite sql_sqlite)
$(qt_feature sqlite system_sqlite)
)
+
qt6-build_src_configure
}
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index a7b3797a..39f291d5 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -25,7 +25,6 @@ QTSQL_IUSE="freetds mysql oci8 odbc postgres +sqlite"
IUSE+=" ${QTGUI_IUSE} ${QTNETWORK_IUSE} ${QTSQL_IUSE} cups gtk icu systemd +udev"
# QtPrintSupport = QtGui + QtWidgets enabled.
# ibus = xkbcommon + dbus, and xkbcommon needs either libinput or X
-# moved vnc logically to QtNetwork as that is upstream condition for it
REQUIRED_USE+="
$(printf '%s? ( gui ) ' ${QTGUI_IUSE//+/})
$(printf '%s? ( network ) ' ${QTNETWORK_IUSE//+/})
@@ -37,6 +36,7 @@ REQUIRED_USE+="
gui? ( || ( eglfs X ) || ( libinput X ) )
libinput? ( udev )
sql? ( || ( freetds mysql oci8 odbc postgres sqlite ) )
+ vnc? ( gui )
X? ( gles2-only? ( egl ) )
"
@@ -173,5 +173,6 @@ src_configure() {
$(qt_feature sqlite sql_sqlite)
$(qt_feature sqlite system_sqlite)
)
+
qt6-build_src_configure
}