aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-10-10 22:20:11 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-10-10 22:20:41 +1100
commitfeaa2356be6949c90be25099f8e69aaa3fa2d3bb (patch)
tree844567bace346b90fb23802b4a0d756dec07a13b
parentqt5-build.eclass: unset variables that, if set, cause configure to fail (diff)
downloadqt-feaa2356be6949c90be25099f8e69aaa3fa2d3bb.tar.gz
qt-feaa2356be6949c90be25099f8e69aaa3fa2d3bb.tar.bz2
qt-feaa2356be6949c90be25099f8e69aaa3fa2d3bb.zip
dev-qt/qtlocation: fix build of 5.9 and later
Bug: https://bugs.gentoo.org/633776 Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-qt/qtlocation/qtlocation-5.10.9999.ebuild8
-rw-r--r--dev-qt/qtlocation/qtlocation-5.9.9999.ebuild8
-rw-r--r--dev-qt/qtlocation/qtlocation-5.9999.ebuild8
3 files changed, 24 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/qtlocation-5.10.9999.ebuild b/dev-qt/qtlocation/qtlocation-5.10.9999.ebuild
index 420e3c9b..06c3a9a1 100644
--- a/dev-qt/qtlocation/qtlocation-5.10.9999.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.10.9999.ebuild
@@ -34,3 +34,11 @@ QT5_TARGET_SUBDIRS=(
src/imports/location
src/plugins/geoservices
)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}
diff --git a/dev-qt/qtlocation/qtlocation-5.9.9999.ebuild b/dev-qt/qtlocation/qtlocation-5.9.9999.ebuild
index 420e3c9b..06c3a9a1 100644
--- a/dev-qt/qtlocation/qtlocation-5.9.9999.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.9.9999.ebuild
@@ -34,3 +34,11 @@ QT5_TARGET_SUBDIRS=(
src/imports/location
src/plugins/geoservices
)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}
diff --git a/dev-qt/qtlocation/qtlocation-5.9999.ebuild b/dev-qt/qtlocation/qtlocation-5.9999.ebuild
index 420e3c9b..06c3a9a1 100644
--- a/dev-qt/qtlocation/qtlocation-5.9999.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.9999.ebuild
@@ -34,3 +34,11 @@ QT5_TARGET_SUBDIRS=(
src/imports/location
src/plugins/geoservices
)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}