aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-02-22 11:54:29 +0200
committerJimi Huotari <chiitoo@gentoo.org>2018-02-22 12:19:49 +0200
commit69102d1618507b0bcf94f166ca7b01735150cdcc (patch)
tree3c74c42737f26e6cf06feb895e23d2e07d1771dc /dev-qt/qdoc
parentdev-qt: add 5.11.0_alpha (diff)
downloadqt-69102d1618507b0bcf94f166ca7b01735150cdcc.tar.gz
qt-69102d1618507b0bcf94f166ca7b01735150cdcc.tar.bz2
qt-69102d1618507b0bcf94f166ca7b01735150cdcc.zip
dev-qt: add changes from 5.9999 to 5.11
The 5.11.9999 ebuilds were mistakingly created using the 5.10.9999 ebuilds as their base, thus missing some of the changes in 5.9999. Thanks to [Arfrever] for pointing it out. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-qt/qdoc')
-rw-r--r--dev-qt/qdoc/qdoc-5.11.0_alpha.ebuild6
-rw-r--r--dev-qt/qdoc/qdoc-5.11.9999.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-qt/qdoc/qdoc-5.11.0_alpha.ebuild b/dev-qt/qdoc/qdoc-5.11.0_alpha.ebuild
index 983d3432..61789076 100644
--- a/dev-qt/qdoc/qdoc-5.11.0_alpha.ebuild
+++ b/dev-qt/qdoc/qdoc-5.11.0_alpha.ebuild
@@ -15,6 +15,7 @@ IUSE="qml"
DEPEND="
~dev-qt/qtcore-${PV}
+ sys-devel/clang:=
qml? ( ~dev-qt/qtdeclarative-${PV} )
"
RDEPEND="${DEPEND}"
@@ -27,5 +28,10 @@ src_prepare() {
qt_use_disable_mod qml qmldevtools-private \
src/qdoc/qdoc.pro
+ export LLVM_INSTALL_DIR="$(llvm-config --prefix)"
+ # this is normally loaded in qttools.pro, so skipped by using
+ # QT_TARGET_SUBDIRS causing build to fail
+ sed -e '1iload(qt_find_clang)\' -i src/qdoc/qdoc.pro || die
+
qt5-build_src_prepare
}
diff --git a/dev-qt/qdoc/qdoc-5.11.9999.ebuild b/dev-qt/qdoc/qdoc-5.11.9999.ebuild
index 983d3432..61789076 100644
--- a/dev-qt/qdoc/qdoc-5.11.9999.ebuild
+++ b/dev-qt/qdoc/qdoc-5.11.9999.ebuild
@@ -15,6 +15,7 @@ IUSE="qml"
DEPEND="
~dev-qt/qtcore-${PV}
+ sys-devel/clang:=
qml? ( ~dev-qt/qtdeclarative-${PV} )
"
RDEPEND="${DEPEND}"
@@ -27,5 +28,10 @@ src_prepare() {
qt_use_disable_mod qml qmldevtools-private \
src/qdoc/qdoc.pro
+ export LLVM_INSTALL_DIR="$(llvm-config --prefix)"
+ # this is normally loaded in qttools.pro, so skipped by using
+ # QT_TARGET_SUBDIRS causing build to fail
+ sed -e '1iload(qt_find_clang)\' -i src/qdoc/qdoc.pro || die
+
qt5-build_src_prepare
}