aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2017-04-18 19:46:19 +0300
committerJimi Huotari <chiitoo@gentoo.org>2017-04-18 19:46:19 +0300
commit42be17c927f52fd0f4b7c2455e67059e7164e17d (patch)
tree3c6ad47144901797c4d3b3fd60b79361785c5046 /dev-qt/qtbluetooth
parentMerge pull request #145 from Chiitoo (diff)
downloadqt-42be17c927f52fd0f4b7c2455e67059e7164e17d.tar.gz
qt-42be17c927f52fd0f4b7c2455e67059e7164e17d.tar.bz2
qt-42be17c927f52fd0f4b7c2455e67059e7164e17d.zip
dev-qt: Add live ebuilds for the 5.9 branch.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-qt/qtbluetooth')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.9.9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.9.9999.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.9.9999.ebuild
new file mode 100644
index 00000000..ca5687bd
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.9.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtconnectivity"
+inherit qt5-build
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtconcurrent-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdbus-${PV}
+ >=net-wireless/bluez-5:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtnetwork-${PV}
+"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build_src_prepare
+}