aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-01-07 21:47:42 +0100
committerDavide Pesavento <pesa@gentoo.org>2019-01-07 21:47:42 +0100
commit9f5cfe5f4abb8e97ac0231301e6c0bdb31d21796 (patch)
treedb21c9c1d05304839208cb7cf70875b0cf212fc1 /dev-qt/qtcore/qtcore-5.9999.ebuild
parentdev-qt: sync KEYWORDS (diff)
downloadqt-9f5cfe5f4abb8e97ac0231301e6c0bdb31d21796.tar.gz
qt-9f5cfe5f4abb8e97ac0231301e6c0bdb31d21796.tar.bz2
qt-9f5cfe5f4abb8e97ac0231301e6c0bdb31d21796.zip
qt5-build.eclass: move the 's/optimize_full//' sed where it belongs
Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-qt/qtcore/qtcore-5.9999.ebuild')
-rw-r--r--dev-qt/qtcore/qtcore-5.9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-qt/qtcore/qtcore-5.9999.ebuild b/dev-qt/qtcore/qtcore-5.9999.ebuild
index a77edf08..2aa86f3a 100644
--- a/dev-qt/qtcore/qtcore-5.9999.ebuild
+++ b/dev-qt/qtcore/qtcore-5.9999.ebuild
@@ -44,6 +44,9 @@ QT5_GENTOO_PRIVATE_CONFIG=(
)
src_prepare() {
+ # don't add -O3 to CXXFLAGS, bug 549140
+ sed -i -e '/CONFIG\s*+=/s/optimize_full//' src/corelib/corelib.pro || die
+
# fix missing qt_version_tag symbol w/ LTO, bug 674382
sed -i -e 's/^gcc:ltcg/gcc/' src/corelib/global/global.pri || die