aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-08-15 13:04:00 +0300
committerJimi Huotari <chiitoo@gentoo.org>2018-08-15 13:04:00 +0300
commit7151cb405a04da9e01990df4786b6df47031dad0 (patch)
treeee258a9ff3dbbfdbdf8bdb079ba0b74d047b4981 /dev-qt/qtgamepad
parentdev-qt/qtwebengine: sync with main Gentoo repo tree (diff)
downloadqt-7151cb405a04da9e01990df4786b6df47031dad0.tar.gz
qt-7151cb405a04da9e01990df4786b6df47031dad0.tar.bz2
qt-7151cb405a04da9e01990df4786b6df47031dad0.zip
dev-qt: add 5.12.9999
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'dev-qt/qtgamepad')
-rw-r--r--dev-qt/qtgamepad/qtgamepad-5.12.9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtgamepad/qtgamepad-5.12.9999.ebuild b/dev-qt/qtgamepad/qtgamepad-5.12.9999.ebuild
new file mode 100644
index 00000000..a7c4b576
--- /dev/null
+++ b/dev-qt/qtgamepad/qtgamepad-5.12.9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Qt module to support gamepad hardware"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="evdev qml sdl"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[evdev?]
+ evdev? ( virtual/libudev:= )
+ sdl? ( media-libs/libsdl )
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod qml quick \
+ src/src.pro
+
+ qt_use_disable_config evdev evdev \
+ src/plugins/gamepads/gamepads.pro
+
+ qt_use_disable_config sdl sdl2 \
+ src/plugins/gamepads/gamepads.pro
+
+ qt5-build_src_prepare
+}