aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-05 21:35:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-05 21:35:03 +0100
commit432d597c23e5d60a5da351f906955672ff233819 (patch)
tree1f2cea0dc40a7f4b99c0eea3dca0a3b1a4087cc8 /dev-qt/qtwebview
parentdev-qt/qtwebengine: fix build with USE="system-icu" (diff)
downloadqt-432d597c23e5d60a5da351f906955672ff233819.tar.gz
qt-432d597c23e5d60a5da351f906955672ff233819.tar.bz2
qt-432d597c23e5d60a5da351f906955672ff233819.zip
dev-qt: Add Qt 5.12.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-qt/qtwebview')
-rw-r--r--dev-qt/qtwebview/Manifest1
-rw-r--r--dev-qt/qtwebview/qtwebview-5.12.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-qt/qtwebview/Manifest b/dev-qt/qtwebview/Manifest
index a5f6a249..e33b0e1d 100644
--- a/dev-qt/qtwebview/Manifest
+++ b/dev-qt/qtwebview/Manifest
@@ -1 +1,2 @@
DIST qtwebview-everywhere-src-5.12.0.tar.xz 130676 BLAKE2B 60f249ebbc928750306c0c020d2788022ea499ab484995a2ed86b7beac5d5512e4211c58ba18ec062ab292b517489839a2ac95c9d9d4f19137eda70360bfabaa SHA512 b6d9b60d86bb6ca4c7ea08ad37619d2a506203b44db559c4dc97d544ed7776e2f8f10c8941d007f20f4f3bac851b86cf0ead70f78d10a8792a1b7a727b1ffdd7
+DIST qtwebview-everywhere-src-5.12.1.tar.xz 130712 BLAKE2B 42bf05507523ad984eeae8bc26aaa5b878edbf3d412c68e491cd715f6d1c06b4aee5e26c7f10346bdf11f0851f9c9fd38b24d598e07b8c1615eee62e6a61564c SHA512 27e1904570678691e26831e87953e47d6b707bfe0504cde112ad6c8c18ea163eb83d90f8d4dbbf73873caee827e486691bb73e16a4c8b9e522bbeffbb68e9973
diff --git a/dev-qt/qtwebview/qtwebview-5.12.1.ebuild b/dev-qt/qtwebview/qtwebview-5.12.1.ebuild
new file mode 100644
index 00000000..1c7076ec
--- /dev/null
+++ b/dev-qt/qtwebview/qtwebview-5.12.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Module for displaying web content in a QML application using the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtwebengine-${PV}
+"
+RDEPEND="${DEPEND}"