aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2017-11-03 19:21:01 +0200
committerJimi Huotari <chiitoo@gentoo.org>2017-11-03 23:11:09 +0200
commitc4d24b73b811d8f571b6a08b82b0e49fb0fa2142 (patch)
tree3b2fb2ef98622e3de280433e7a537774e970ae35 /lxqt-base/lxqt-config
parenttravis: update (diff)
downloadqt-c4d24b73b811d8f571b6a08b82b0e49fb0fa2142.tar.gz
qt-c4d24b73b811d8f571b6a08b82b0e49fb0fa2142.tar.bz2
qt-c4d24b73b811d8f571b6a08b82b0e49fb0fa2142.zip
lxqt-base: add live ebuilds for the LXQt packages
Compared to Portage, 'lxqt-common' has been dropped, and 'lxqt-themes' has been added.
Diffstat (limited to 'lxqt-base/lxqt-config')
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-9999.ebuild58
-rw-r--r--lxqt-base/lxqt-config/metadata.xml8
2 files changed, 66 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-config/lxqt-config-9999.ebuild b/lxqt-base/lxqt-config/lxqt-config-9999.ebuild
new file mode 100644
index 00000000..4960d23d
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="|| ( GPL-2 LGPL-2.1+ )"
+SLOT="0"
+
+CDEPEND="
+ >=dev-libs/libqtxdg-2.0.0
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ kde-plasma/libkscreen:5=
+ lxqt-base/liblxqt
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes
+"
+DEPEND="${CDEPEND}
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.3.1
+"
+RDEPEND="${CDEPEND}
+ x11-apps/setxkbmap
+"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
diff --git a/lxqt-base/lxqt-config/metadata.xml b/lxqt-base/lxqt-config/metadata.xml
new file mode 100644
index 00000000..a40a83a9
--- /dev/null
+++ b/lxqt-base/lxqt-config/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+</pkgmetadata>