aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-07-04 05:10:00 +1000
committerMichael Palimaka <kensington@gentoo.org>2012-07-04 05:10:00 +1000
commitf790db1900d46fad0de339aa05e66229e2be88d9 (patch)
tree6033231c621f72fd29f630a18e83ae4d044f5901 /media-gfx
parent[dev-util/monkeystudio] Remove, package has been moved to the main tree. (diff)
downloadqt-f790db1900d46fad0de339aa05e66229e2be88d9.tar.gz
qt-f790db1900d46fad0de339aa05e66229e2be88d9.tar.bz2
qt-f790db1900d46fad0de339aa05e66229e2be88d9.zip
[media-gfx/qosmic] Add live ebuild for bug #339467.
(Portage version: 2.1.11.4/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/qosmic/metadata.xml9
-rw-r--r--media-gfx/qosmic/qosmic-9999.ebuild27
2 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/qosmic/metadata.xml b/media-gfx/qosmic/metadata.xml
new file mode 100644
index 00000000..a1247f0f
--- /dev/null
+++ b/media-gfx/qosmic/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="google-code">qosmic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/qosmic/qosmic-9999.ebuild b/media-gfx/qosmic/qosmic-9999.ebuild
new file mode 100644
index 00000000..185f449c
--- /dev/null
+++ b/media-gfx/qosmic/qosmic-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit qt4-r2 subversion
+
+DESCRIPTION="A cosmic recursive flame fractal editor"
+HOMEPAGE="http://code.google.com/p/qosmic/"
+ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk/${PN}/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1.4
+ =media-gfx/flam3-9999
+ >=x11-libs/qt-gui-4.6:4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="changes.txt README"
+
+src_configure() {
+ eqmake4 "CONFIG += link_pkgconfig"
+}