aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-09-23 16:18:33 +0300
committerJimi Huotari <chiitoo@gentoo.org>2018-09-23 17:57:38 +0300
commit182b079cd39004a600b9dddce6d47449574fd5fc (patch)
tree1aa34804485a78180ae20a9f85e9774522e8582c /x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
parentlxqt-base/lxqt-themes: move to x11-themes/lxqt-themes (diff)
downloadqt-182b079cd39004a600b9dddce6d47449574fd5fc.tar.gz
qt-182b079cd39004a600b9dddce6d47449574fd5fc.tar.bz2
qt-182b079cd39004a600b9dddce6d47449574fd5fc.zip
lxqt: sync related ebuilds/metadata with the main Gentoo repo tree
With this, the metadata and 9999 ebuilds are in sync with the 0.13.0 versions found via the official Gentoo repository tree, with the following exceptions: - Polkit is optional. - Some of the USE-flags are not used/included in the metadata. - A patch for 'lxqt-config' is not needed. - The handling of translations has been changed upstream, so 'lxqt-meta' does not depend on 'lxqt-l10n' due to file collisions. Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'x11-themes/lxqt-themes/lxqt-themes-9999.ebuild')
-rw-r--r--x11-themes/lxqt-themes/lxqt-themes-9999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild b/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
index ffeba25a..4760bcad 100644
--- a/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
+++ b/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
@@ -1,24 +1,25 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit cmake-utils
-DESCRIPTION="Themes, graphics, and icons for LXQt"
-HOMEPAGE="http://lxqt.org/"
+DESCRIPTION="Themes, graphics and icons for LXQt"
+HOMEPAGE="https://lxqt.org/"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} = *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/lxde/${PN}.git"
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
- SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64"
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="LGPL-2.1+"
SLOT="0"
-DEPEND="
- >=dev-util/lxqt-build-tools-0.1.0
- !!lxqt-base/lxqt-common
+RDEPEND="!lxqt-base/lxqt-common"
+DEPEND="${RDEPEND}
+ >=dev-util/lxqt-build-tools-0.5.0
"