aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-qt/qtcore/qtcore-5.14.9999.ebuild10
-rw-r--r--dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild10
-rw-r--r--dev-qt/qtcore/qtcore-5.15.9999.ebuild10
-rw-r--r--dev-qt/qtcore/qtcore-5.9999.ebuild10
4 files changed, 24 insertions, 16 deletions
diff --git a/dev-qt/qtcore/qtcore-5.14.9999.ebuild b/dev-qt/qtcore/qtcore-5.14.9999.ebuild
index 14b4d293..8fe97564 100644
--- a/dev-qt/qtcore/qtcore-5.14.9999.ebuild
+++ b/dev-qt/qtcore/qtcore-5.14.9999.ebuild
@@ -50,8 +50,8 @@ pkg_pretend() {
use kernel_linux || return
get_running_version
if kernel_is -lt 3 17 && ! use old-kernel; then
- ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for ${CATEGORY}/${PN}"
- ewarn "to function on this kernel properly. See Bug #669994."
+ ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for"
+ ewarn "dev-qt/qtcore to function on this kernel properly. See Bug #669994."
fi
}
@@ -70,10 +70,12 @@ src_configure() {
-no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
- $(qt_use !old-kernel feature-renameat2) # needs Linux 3.16, bug 669994
- $(qt_use !old-kernel feature-getentropy) # needs Linux 3.17, bug 669994
$(qt_use systemd journald)
)
+ use old-kernel && myconf+=(
+ -no-feature-renameat2 # needs Linux 3.16, bug 669994
+ -no-feature-getentropy # needs Linux 3.17, bug 669994
+ )
qt5-build_src_configure
}
diff --git a/dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild b/dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild
index 14b4d293..8fe97564 100644
--- a/dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild
+++ b/dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild
@@ -50,8 +50,8 @@ pkg_pretend() {
use kernel_linux || return
get_running_version
if kernel_is -lt 3 17 && ! use old-kernel; then
- ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for ${CATEGORY}/${PN}"
- ewarn "to function on this kernel properly. See Bug #669994."
+ ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for"
+ ewarn "dev-qt/qtcore to function on this kernel properly. See Bug #669994."
fi
}
@@ -70,10 +70,12 @@ src_configure() {
-no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
- $(qt_use !old-kernel feature-renameat2) # needs Linux 3.16, bug 669994
- $(qt_use !old-kernel feature-getentropy) # needs Linux 3.17, bug 669994
$(qt_use systemd journald)
)
+ use old-kernel && myconf+=(
+ -no-feature-renameat2 # needs Linux 3.16, bug 669994
+ -no-feature-getentropy # needs Linux 3.17, bug 669994
+ )
qt5-build_src_configure
}
diff --git a/dev-qt/qtcore/qtcore-5.15.9999.ebuild b/dev-qt/qtcore/qtcore-5.15.9999.ebuild
index 14b4d293..8fe97564 100644
--- a/dev-qt/qtcore/qtcore-5.15.9999.ebuild
+++ b/dev-qt/qtcore/qtcore-5.15.9999.ebuild
@@ -50,8 +50,8 @@ pkg_pretend() {
use kernel_linux || return
get_running_version
if kernel_is -lt 3 17 && ! use old-kernel; then
- ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for ${CATEGORY}/${PN}"
- ewarn "to function on this kernel properly. See Bug #669994."
+ ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for"
+ ewarn "dev-qt/qtcore to function on this kernel properly. See Bug #669994."
fi
}
@@ -70,10 +70,12 @@ src_configure() {
-no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
- $(qt_use !old-kernel feature-renameat2) # needs Linux 3.16, bug 669994
- $(qt_use !old-kernel feature-getentropy) # needs Linux 3.17, bug 669994
$(qt_use systemd journald)
)
+ use old-kernel && myconf+=(
+ -no-feature-renameat2 # needs Linux 3.16, bug 669994
+ -no-feature-getentropy # needs Linux 3.17, bug 669994
+ )
qt5-build_src_configure
}
diff --git a/dev-qt/qtcore/qtcore-5.9999.ebuild b/dev-qt/qtcore/qtcore-5.9999.ebuild
index fc5723d2..ff1430d7 100644
--- a/dev-qt/qtcore/qtcore-5.9999.ebuild
+++ b/dev-qt/qtcore/qtcore-5.9999.ebuild
@@ -49,8 +49,8 @@ pkg_pretend() {
use kernel_linux || return
get_running_version
if kernel_is -lt 3 17 && ! use old-kernel; then
- ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for ${CATEGORY}/${PN}"
- ewarn "to function on this kernel properly. See Bug #669994."
+ ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for"
+ ewarn "dev-qt/qtcore to function on this kernel properly. See Bug #669994."
fi
}
@@ -69,10 +69,12 @@ src_configure() {
-no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
- $(qt_use !old-kernel feature-renameat2) # needs Linux 3.16, bug 669994
- $(qt_use !old-kernel feature-getentropy) # needs Linux 3.17, bug 669994
$(qt_use systemd journald)
)
+ use old-kernel && myconf+=(
+ -no-feature-renameat2 # needs Linux 3.16, bug 669994
+ -no-feature-getentropy # needs Linux 3.17, bug 669994
+ )
qt5-build_src_configure
}