aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyside-tools/pyside-tools-9999.ebuild')
-rw-r--r--dev-python/pyside-tools/pyside-tools-9999.ebuild38
1 files changed, 11 insertions, 27 deletions
diff --git a/dev-python/pyside-tools/pyside-tools-9999.ebuild b/dev-python/pyside-tools/pyside-tools-9999.ebuild
index 02b8a105..95fa3e0d 100644
--- a/dev-python/pyside-tools/pyside-tools-9999.ebuild
+++ b/dev-python/pyside-tools/pyside-tools-9999.ebuild
@@ -4,26 +4,19 @@
EAPI=6
CMAKE_IN_SOURCE_BUILD="1"
-
-#FIXME: Restore Python 2.7 support after this upstream issue is resolved:
-# https://bugreports.qt.io/browse/PYSIDE-508
-#Even after this issue is resolved, further ebuild changes will probably be
-#needed to fully support Python 2.7. Unlike PySide2 and Shiboken2, the root
-#"CMakeLists.txt" file in pyside2-tools provides no ${PYTHON_EXECUTABLE} option.
-#Instead, the ${PYTHON_EXTENSION_SUFFIX} and ${PYTHON_BASENAME} options must be
-#passed with values specific to Python 2.7. Additionally, note that the
-#"python2.7-config" command provides no "--extension-suffix" option.
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit cmake-utils python-r1 virtualx git-r3
DESCRIPTION="PySide development tools (lupdate, rcc, uic)"
HOMEPAGE="https://wiki.qt.io/PySide2"
-EGIT_REPO_URI="https://code.qt.io/pyside/${PN}.git"
-#FIXME: Switch to the clang-enabled "dev" branch once stable.
-EGIT_BRANCH="5.6"
+EGIT_REPO_URI="https://code.qt.io/pyside/pyside-tools.git"
+EGIT_BRANCH="5.9"
-LICENSE="BSD GPL-2"
+# Although "LICENSE-uic" suggests the "pyside2uic" directory to be dual-licensed
+# under the BSD 3-clause and GPL v2 licenses, this appears to be an oversight;
+# all files in this (and every) directory are licensed only under the GPL v2.
+LICENSE="GPL-2"
SLOT="2"
KEYWORDS=""
IUSE="test"
@@ -76,26 +69,17 @@ src_configure() {
-DBUILD_TESTS=$(usex test)
)
+ # Find the previously installed "Shiboken2Config.*.cmake" and
+ # "PySide2Config.*.cmake" files specific to this Python version.
if python_is_python3; then
# Extension tag unique to the current Python 3.x version (e.g.,
# ".cpython-34m" for CPython 3.4).
local EXTENSION_TAG="$("$(python_get_PYTHON_CONFIG)" --extension-suffix)"
EXTENSION_TAG="${EXTENSION_TAG%.so}"
- mycmakeargs+=(
- #FIXME: Submit an upstream PySide2 issue requesting that the
- #"PySide2Config.cmake" file use the same
- #${PYTHON_EXTENSION_SUFFIX} variable as the
- #"Shiboken2Config.cmake" file.
-
- # Find the previously installed "Shiboken2Config.*.cmake" and
- # "PySide2Config.*.cmake" files specific to this Python 3.x
- # version.
- -DPYTHON_EXTENSION_SUFFIX="${EXTENSION_TAG}"
- -DPYTHON_BASENAME="${EXTENSION_TAG}"
- )
+ mycmakeargs+=( -DPYTHON_CONFIG_SUFFIX="${EXTENSION_TAG}" )
else
- die "Python 2.7 currently unsupported."
+ mycmakeargs+=( -DPYTHON_CONFIG_SUFFIX="-python2.7" )
fi
CMAKE_USE_DIR="${BUILD_DIR}" cmake-utils_src_configure