aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2014-07-03 00:40:49 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2014-07-03 00:40:49 +0200
commit01ff3a2d6b36716aa83e749acfeb4cc09e076ba8 (patch)
tree1791cb0a947107a9d69386c2edb927f669f8cd3b
parentsci-biology/tablet: cleaned up the ebuilds, they compile and install but the ... (diff)
downloadsci-01ff3a2d6b36716aa83e749acfeb4cc09e076ba8.tar.gz
sci-01ff3a2d6b36716aa83e749acfeb4cc09e076ba8.tar.bz2
sci-01ff3a2d6b36716aa83e749acfeb4cc09e076ba8.zip
sci-biology/tablet-bin: version bump; updated the license
Package-Manager: portage-2.2.7
-rw-r--r--sci-biology/tablet-bin/ChangeLog6
-rw-r--r--sci-biology/tablet-bin/Manifest1
-rw-r--r--sci-biology/tablet-bin/tablet-bin-1.14.04.10.ebuild97
3 files changed, 104 insertions, 0 deletions
diff --git a/sci-biology/tablet-bin/ChangeLog b/sci-biology/tablet-bin/ChangeLog
index d48473ae8..8b3878105 100644
--- a/sci-biology/tablet-bin/ChangeLog
+++ b/sci-biology/tablet-bin/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*tablet-bin-1.14.04.10 (02 Jul 2014)
+
+ 02 Jul 2014; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ +tablet-bin-1.14.04.10.ebuild:
+ sci-biology/tablet-bin: version bump; updated the license
+
*tablet-bin-1.13.12.17 (20 Jan 2014)
20 Jan 2014; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
diff --git a/sci-biology/tablet-bin/Manifest b/sci-biology/tablet-bin/Manifest
index ae1e4a6af..7c1877c79 100644
--- a/sci-biology/tablet-bin/Manifest
+++ b/sci-biology/tablet-bin/Manifest
@@ -1,2 +1,3 @@
DIST coveragestats.py 4800 SHA256 358b686d00fd75d2cc9af490b0e7d635f74cbb1c0b153df22d8ff879884d47bc SHA512 d5688832c13dc9c2e2e015df0b5c50113f72e2eeae076d479c43b65a4b028f8dcfa5f0fb833b4341d76d3956ea27707c55a51389b73a2efed6abd2b96ccdc3cd WHIRLPOOL 0b1eb20189b343d6014097748c053f35f8ad162400312cfbde16bac7fee52f24ac8b0055e991c823dcb64d7a20df3fbb88d8cd6119f838d4e9a5f26e82604664
DIST tablet-bin-1.13.12.17.sh 34395356 SHA256 fab481dd2a19e1c25142c41e75c483eeac36cc6793921a2643d9472f0aecbd2b SHA512 6fee28fd68ac4dde777dc7b873735e165d19bec47997a49185f21eecaaf2f38ca019b5af30ff18177ed69ad01eb8a797ef8b892631780ad548bf8fdf3ceb2f0b WHIRLPOOL 274e3849096179707af5ad36001ba060b5c5be068350454553997a120ec5c5f33b347ea26f3f9bd356bb7191b1c1e07199a6f6c0073e5b7edb7bf953d46c0974
+DIST tablet-bin-1.14.04.10.sh 36267340 SHA256 d716eab1c4f8f7de099bed6b10a7346fcc2340cf69e527e5af33f521fad00b97 SHA512 9ef7f3332171f66bee6cfceb46dae56170fc744709bc34ebcd6abf201b8d4dd9f6a3e21b61ec341297b66c1b2527970cd15715d1b87f9b864ac97aae4f994ac9 WHIRLPOOL 0369d8bd46ce3ce5bd4da66f23d21a47dcdb74bfa54ff7748fd1ae28180c3ec300eb1e02caeeb8f7090e908fe3984bd14845d9a4e5c099e76bd67ee562759124
diff --git a/sci-biology/tablet-bin/tablet-bin-1.14.04.10.ebuild b/sci-biology/tablet-bin/tablet-bin-1.14.04.10.ebuild
new file mode 100644
index 000000000..1a0fdf12d
--- /dev/null
+++ b/sci-biology/tablet-bin/tablet-bin-1.14.04.10.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit java-pkg-2 python-r1
+
+DESCRIPTION="Viewer of next generation sequence assemblies and alignments."
+HOMEPAGE="http://bioinf.scri.ac.uk/tablet/"
+SRC_URI="
+ x86? ( http://bioinf.scri.ac.uk/tablet/installers/tablet_linux_x86_$(replace_all_version_separators _).sh -> ${P}.sh )
+ amd64? ( http://bioinf.scri.ac.uk/tablet/installers/tablet_linux_x64_$(replace_all_version_separators _).sh -> ${P}.sh )
+ http://bioinf.scri.ac.uk/tablet/additional/coveragestats.py"
+
+# Upstream says regarding source code unavailability:
+# Tablet uses a modified version of the BSD License which has been edited to
+# remove references to distribution and use in source forms. This means that
+# we are happy for you to distribute and use Tablet however you please, but we
+# do not (yet) want to make the source code publicly available.
+
+# The licence file itself is in the installer, and ends up on disk after
+# installation at /opt/Tablet/docs/tablet.html
+# The original BSD licence was modified to remove references to distribution
+# and use in source forms, because we cannot make the source code available
+# for Tablet.
+
+LICENSE="Tablet"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ virtual/jre"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local file
+ for file in ${A}; do
+ cp "${DISTDIR}"/${file} "${WORKDIR}" || die
+ done
+}
+
+src_install() {
+ # In theory it seems this binary package could be installed through ant
+ # instead of the install4j package which is not easy to be forced
+ # non-interactive. The below approach via install4j is not ideal but works.
+ sed "s#\"\${D}\"#\"${D}\"#g" "${FILESDIR}"/response.varfile > "${WORKDIR}"/response.varfile || die "sed failed"
+
+ # the intallation script somehow does not pickup
+ # -varfile="${DISTDIR}"/response.varfile from the commandline and therefore
+ # we place the file rather directly into the place where it should reside.
+ # In the file you can read details how the variables were mangled. For
+ # example, the trick with sys.symlinkDir in the response.varfile is to
+ # disable the installation process to symlink from /usr/local/bin/table to
+ # /opt/Tablet/tablet. That was logged in that file with the following line:
+ #
+ # /var/tmp/portage/sci-biology/tablet-bin-1.11.02.18/image/opt/Tablet/.install4j/installation.log:
+ # Variable changed: sys.symlinkDir=/usr/local/bin[class java.lang.String]
+ #
+ # The file is then left on the installed system in "${D}"/opt/Tablet/.install4j/response.varfile
+ dodir /opt/Tablet/.install4j
+ cat "${WORKDIR}"/response.varfile > "${ED}"/opt/Tablet/.install4j/response.varfile || die
+
+ # make sure we force java to point a to $HOME which is inside our sanbox
+ # directory area. We force -Duser.home . It seems also -Dinstall4j.userHome
+ # could be done based on the figure shown at http://resources.ej-technologies.com/install4j/help/doc/
+ sed \
+ -e "s#/bin/java\" -Dinstall4j.jvmDir#/bin/java\" -Duser.home="${TMPDIR}" -Dinstall4j.jvmDir#" \
+ -i "${WORKDIR}"/${P}.sh || die
+ sh \
+ "${WORKDIR}"/${P}.sh \
+ -q -overwrite \
+ -varfile="${DISTDIR}"/response.varfile \
+ --destination="${ED}"/opt/Tablet \
+ -dir "${ED}"/opt/Tablet || die
+
+ rm -rf "${ED}"/opt/Tablet/jre || die
+
+ # this dies with tablet-bin-1.14.04.10 with
+ # * python2_7: running python_doscript /mnt/1TB/var/tmp/portage/sci-biology/tablet-bin-1.14.04.10/work/coveragestats.py
+ # * The file has incompatible shebang:
+ # * file: /usr/lib/python-exec/python2.7/coveragestats.py
+ # * current shebang: #!/usr/bin/env python
+ # * requested impl: python2.7
+ #
+ # python_foreach_impl python_doscript "${WORKDIR}"/coveragestats.py
+
+ echo "PATH=${EPREFIX}/opt/Tablet" > 99Tablet
+ doenvd 99Tablet || die
+}