aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgienah <gienah@gentoo.org>2014-10-13 23:34:48 +1100
committergienah <gienah@gentoo.org>2014-10-13 23:34:48 +1100
commit1d5913ef88752e094b1b45a8ca501ef2319faf90 (patch)
tree4474b2b127cdcb0f2d86775380db3781168729e8
parentBump the cblas virtual to add int64 supplort for cblas-reference. (diff)
downloadsci-1d5913ef88752e094b1b45a8ca501ef2319faf90.tar.gz
sci-1d5913ef88752e094b1b45a8ca501ef2319faf90.tar.bz2
sci-1d5913ef88752e094b1b45a8ca501ef2319faf90.zip
Specify the xblas library location to cmake - sci-libs/lapack-reference-9999::science USE="int64 static-libs {test*} xblas*" ABI_X86="32 (64) (-x32)" builds and passes tests with eselect blas show = reference
-rw-r--r--sci-libs/lapack-reference/ChangeLog6
-rw-r--r--sci-libs/lapack-reference/lapack-reference-9999.ebuild2
2 files changed, 8 insertions, 0 deletions
diff --git a/sci-libs/lapack-reference/ChangeLog b/sci-libs/lapack-reference/ChangeLog
index 4fcbb7b81..89abcfebb 100644
--- a/sci-libs/lapack-reference/ChangeLog
+++ b/sci-libs/lapack-reference/ChangeLog
@@ -3,6 +3,12 @@
# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/ChangeLog,v 1.51 2010/10/02 20:49:51 grobian Exp $
13 Oct 2014; Mark Wright <gienah@gentoo.org> lapack-reference-9999.ebuild:
+ Specify the xblas library location to cmake -
+ sci-libs/lapack-reference-9999::science USE="int64 static-libs {test*}
+ xblas*" ABI_X86="32 (64) (-x32)" builds and passes tests with eselect blas
+ show = reference
+
+ 13 Oct 2014; Mark Wright <gienah@gentoo.org> lapack-reference-9999.ebuild:
Refactor to lapack-reference use the fortran-int64.eclass. Add the virtual to
PDEPEND. Call fortran-int64_ensure_blas to check the blas pkg-config file is
available, and the blas-int64 pkg-config file if the int64 USE flag is
diff --git a/sci-libs/lapack-reference/lapack-reference-9999.ebuild b/sci-libs/lapack-reference/lapack-reference-9999.ebuild
index 75000ddd0..0ba3b3fd0 100644
--- a/sci-libs/lapack-reference/lapack-reference-9999.ebuild
+++ b/sci-libs/lapack-reference/lapack-reference-9999.ebuild
@@ -79,6 +79,7 @@ src_configure() {
local libname="${profname//-/_}"
local blas_profname=$(fortran-int64_get_blas_profname)
local xblas_profname=$(fortran-int64_get_xblas_profname)
+ local xblas_libname="${xblas_profname//-/_}"
local blas_requires="${blas_profname}"
use xblas && \
blas_requires+=" ${xblas_profname}"
@@ -94,6 +95,7 @@ src_configure() {
-DCMAKE_CXX_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CXXFLAGS}"
-DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) $(get_abi_CFLAGS) $(fortran-int64_get_fortran_int64_abi_fflags) ${FCFLAGS}"
-DLAPACK_PKGCONFIG_FFLAGS="$(fortran-int64_get_fortran_int64_abi_fflags)"
+ -DXBLAS_LIBRARY:FILEPATH="${ROOT}usr/$(get_libdir)/lib${xblas_libname}.so"
)
if $(fortran-int64_is_static_build); then
mycmakeargs+=(