aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2012-02-16 13:13:12 +0100
committerKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2012-02-16 13:13:12 +0100
commit4aacdbef98a754652a1e35d64c9e6f615efea953 (patch)
treeed5c9a7f8eaaa0a9b045e54b95a0d02a5a224dc5
parentRemove Forthon until legal issues are cleared (diff)
downloadsci-4aacdbef98a754652a1e35d64c9e6f615efea953.tar.gz
sci-4aacdbef98a754652a1e35d64c9e6f615efea953.tar.bz2
sci-4aacdbef98a754652a1e35d64c9e6f615efea953.zip
[media-gfx/PhiloGL] Initial import, ebuild written by me
-rw-r--r--media-gfx/PhiloGL/Manifest1
-rw-r--r--media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild38
-rw-r--r--media-gfx/PhiloGL/metadata.xml8
3 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/PhiloGL/Manifest b/media-gfx/PhiloGL/Manifest
new file mode 100644
index 000000000..4e53b2478
--- /dev/null
+++ b/media-gfx/PhiloGL/Manifest
@@ -0,0 +1 @@
+DIST PhiloGL-1.4.2.zip 2494596 SHA256 88df1501ee4b4775fbda0726b29661c97cd90c287fb365086b8ecbfe01c1a079 SHA512 60fb2909c447b5e54e5d058e9c938da865780802431f02b253545f104ad90c058b19104493cd955c622448262ac36094e6600844a1d77d7e53542a46de0e9e93 WHIRLPOOL 2e9de2e4ae4649b7682feec5da072dd89748514a33679d91a8e4fa037fdc5e4c9e905c68ce2d200b4a4116976de1db95a49f99e6f351b413e740d2abe1c689fe
diff --git a/media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild b/media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild
new file mode 100644
index 000000000..5389bcfcf
--- /dev/null
+++ b/media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="WebGL Framework for Data Vis, Creative Coding and Game Development"
+HOMEPAGE="http://www.senchalabs.org/philogl/"
+SRC_URI="http://www.senchalabs.org/philogl/downloads/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+S=${WORKDIR}
+
+src_prepare() {
+ if use examples ; then
+ for f in $(find ${S}/examples -name index.html); do
+ sed -e "s:../../../build:/usr/share/${PN}:g" \
+ -e "s:../../build:/usr/share/${PN}:g" \
+ -i ${f} || die
+ done
+ sed -e "s:../../../shaders/:/usr/share/${PN}/shaders/:" \
+ -i examples/lessons/{14,15,16}/index.js || die
+ fi
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r build/* shaders
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/media-gfx/PhiloGL/metadata.xml b/media-gfx/PhiloGL/metadata.xml
new file mode 100644
index 000000000..6629da3fa
--- /dev/null
+++ b/media-gfx/PhiloGL/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+</pkgmetadata>