aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2014-03-25 11:46:38 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2014-03-25 11:46:38 +0100
commit87320a08fb1de005c38354df180351bf417bf341 (patch)
treebb3ae1dbcbd29f3999c3a3ea01169f84e77ec03e
parentsci-biology/cutadapt: switch to use newer source code location, add support f... (diff)
parentsci-libs/mkl: Version Bump (diff)
downloadsci-87320a08fb1de005c38354df180351bf417bf341.tar.gz
sci-87320a08fb1de005c38354df180351bf417bf341.tar.bz2
sci-87320a08fb1de005c38354df180351bf417bf341.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci
-rw-r--r--sci-libs/mkl/ChangeLog5
-rw-r--r--sci-libs/mkl/Manifest1
-rw-r--r--sci-libs/mkl/mkl-11.1.2.144.ebuild141
3 files changed, 147 insertions, 0 deletions
diff --git a/sci-libs/mkl/ChangeLog b/sci-libs/mkl/ChangeLog
index 230741eee..5d8927ce8 100644
--- a/sci-libs/mkl/ChangeLog
+++ b/sci-libs/mkl/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mkl-11.1.2.144 (24 Mar 2014)
+
+ 24 Mar 2014; Justin Lecher <jlec@gentoo.org> +mkl-11.1.2.144.ebuild:
+ Version Bump
+
*mkl-11.1.1.106 (21 Feb 2014)
21 Feb 2014; Justin Lecher <jlec@gentoo.org> +mkl-11.1.1.106.ebuild:
diff --git a/sci-libs/mkl/Manifest b/sci-libs/mkl/Manifest
index 9183b40cc..89d4bdc00 100644
--- a/sci-libs/mkl/Manifest
+++ b/sci-libs/mkl/Manifest
@@ -1,2 +1,3 @@
DIST parallel_studio_xe_2013_sp1.tgz 3294385739 SHA256 ba65fdf7afbac0276a948ef8d4e1578297a0115548d5f3465c7ed4012030f696 SHA512 ee7995d39b604de6fed0bb87535c48666ca9ffa13975b6adcce170d746f2ee648b5c4a428ed8ef196226f204b3b17a833f379ab4fa57b4a1ebe7c89cc899ea66 WHIRLPOOL 213c8261c161df80732d958bf9e13a286aca2dd6ce16be30fee92d626051bc855c4a1ffe82b12f1bf9095771ca5b128463d839c14748d086b50527e7d09b76a7
DIST parallel_studio_xe_2013_sp1_update1.tgz 3402142370 SHA256 5d0147c6907ed7950d7f14b615785f5e3c7977c62368f4a8ec7b06be758d614a SHA512 ce3f7a9710b3ec6eba5d4f97c9d7bd4cc633119750962d4de5a89b328a22323f5df68f679289930fa8651ee45fb59f7af63d943f9ef175799ab55dfbcc6d8029 WHIRLPOOL eeeef9e46e73f6eb2a1b5f5b9c8c604ff3c4709a53004d9a1887dbe690e0c597dbc683f4b19a8c544ea706e6cefbeedc5d1e6f12ca103cc6bdc35927250f5626
+DIST parallel_studio_xe_2013_sp1_update2.tgz 3410174020 SHA256 235c0f54832879e27afa2c11d7a4cc72bd5bcc6241963024a28cc9e1c74342f0 SHA512 589dee0cf806ac54be473d0a8a0b9da818898f7b91fec88c07c61f45973b6e40fe4a247bb140110a0be0c1422ddcfc0cd1007f2dc58e5ead0e4c77b25806aa4d WHIRLPOOL efde8852a8a708df4c161666f44404157ce4af776c0f2e2ddfdb039a2ca23af5fa68411e2adeba17f7a97b1a11c7e3e74e6806d0a4dcbe614752715161aa7e24
diff --git a/sci-libs/mkl/mkl-11.1.2.144.ebuild b/sci-libs/mkl/mkl-11.1.2.144.ebuild
new file mode 100644
index 000000000..e78e1b1a2
--- /dev/null
+++ b/sci-libs/mkl/mkl-11.1.2.144.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=3949
+INTEL_DPV=2013_sp1_update2
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp multilib alternatives-2
+
+DESCRIPTION="Intel Math Kernel Library: linear algebra, fft, math functions"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-mkl/"
+
+IUSE=""
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=""
+RDEPEND=">=dev-libs/intel-common-13"
+
+CHECKREQS_DISK_BUILD=2500M
+
+INTEL_BIN_RPMS="
+ mkl mkl-devel
+ mkl-cluster mkl-cluster-devel
+ mkl-f95-devel
+ mkl-gnu mkl-gnu-devel
+ mkl-pgi mkl-pgi-devel"
+# single arch packages
+# mkl-mic mkl-mic-devel
+# mkl-sp2dp mkl-sp2dp-devel
+INTEL_DAT_RPMS="mkl-common mkl-cluster-common mkl-f95-common"
+
+src_prepare() {
+ chmod u+w -R opt
+}
+
+mkl_add_prof() {
+ local pcname=${1} libs cflags x
+ shift
+ [[ ${pcname} = *int64* ]] && cflags=-DMKL_ILP64
+ cat <<-EOF > ${pcname}.pc
+ prefix=${INTEL_SDP_EDIR}/mkl
+ libdir=\${prefix}/lib/${IARCH}
+ libdir_comp=${INTEL_SDP_EDIR}/compiler/lib/${IARCH}
+ includedir=\${prefix}/include
+ Name: ${pcname}
+ Description: ${DESCRIPTION}
+ Version: ${PV}
+ URL: ${HOMEPAGE}
+ Libs: -L\${libdir} -L\${libdir_comp} ${libs}
+ Cflags: -I\${includedir} ${cflags}
+ EOF
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${pcname}.pc
+ for x in $*; do
+ alternatives_for ${x} ${pcname/-${x}} 0 \
+ /usr/$(get_libdir)/pkgconfig/${x}.pc ${pcname}.pc
+ done
+}
+
+# mkl_prof [_ilp64 or _lp64]
+# help: http://software.intel.com/en-us/articles/intel-mkl-link-line-advisor/
+mkl_prof() {
+ local bits=""
+ if [[ ${IARCH} == intel64 ]]; then
+ bits=_lp64
+ [[ ${1} == int64 ]] && bits=_ilp64
+ fi
+ local gf="-Wl,--start-group -lmkl_gf${bits}"
+ local intel="-Wl,--start-group -lmkl_intel${bits}"
+ local core="-lmkl_core -Wl,--end-group"
+ local prof=mkl${IARCH:((${#IARCH} - 2)):2}
+ [[ ${1} == int64 ]] && prof=${prof}-int64
+ local libs
+
+ libs="${gf} -lmkl_sequential ${core} -lpthread" \
+ mkl_add_prof ${prof}-gfortran blas lapack
+ libs="${intel} -lmkl_sequential ${core} -lpthread" \
+ mkl_add_prof ${prof}-intel blas lapack cblas lapacke
+ libs="${gf} -lmkl_gnu_thread ${core} -fopenmp -lpthread" \
+ mkl_add_prof ${prof}-gfortran-openmp blas lapack
+ libs="${intel} -lmkl_gnu_thread ${core} -fopenmp -lpthread" \
+ mkl_add_prof ${prof}-gcc-openmp cblas lapacke
+ libs="${intel} -lmkl_intel_thread ${core} -openmp -lpthread" \
+ mkl_add_prof ${prof}-intel-openmp blas lapack cblas lapacke
+ libs="-lmkl_rt -lpthread" \
+ mkl_add_prof ${prof}-dynamic blas lapack cblas lapacke
+ libs="-lmkl_rt -liomp5 -lpthread" \
+ mkl_add_prof ${prof}-dynamic-openmp blas lapack cblas lapacke
+
+ # blacs and scalapack
+ local scal="-lmkl_scalapack${bits:-_core}"
+ local blacs="-lmkl_blacs_intelmpi${bits}"
+ core="-lmkl_core ${blacs} -Wl,--end-group"
+
+ libs="${gf} -lmkl_sequential ${core} -lpthread" \
+ mkl_add_prof ${prof}-gfortran-blacs blacs
+ libs="${scal} ${gf} -lmkl_sequential ${core} -lpthread" \
+ mkl_add_prof ${prof}-gfortran-scalapack scalapack
+ libs="${intel} -lmkl_sequential ${core} -lpthread" \
+ mkl_add_prof ${prof}-intel-blacs blacs
+ libs="${scal} ${intel} -lmkl_sequential ${core} -lpthread" \
+ mkl_add_prof ${prof}-intel-scalapack scalapack
+ libs="${gf} -lmkl_gnu_thread ${core} -fopenmp -lpthread" \
+ mkl_add_prof ${prof}-gfortran-openmp-blacs blacs
+ libs="${scal} ${gf} -lmkl_gnu_thread ${core} -fopenmp -lpthread" \
+ mkl_add_prof ${prof}-gfortran-openmp-scalapack scalapack
+ libs="${intel} -lmkl_gnu_thread ${core} -fopenmp -lpthread" \
+ mkl_add_prof ${prof}-gcc-openmp-blacs blacs
+ libs="${scal} ${intel} -lmkl_gnu_thread ${core} -fopenmp -lpthread" \
+ mkl_add_prof ${prof}-gcc-openmp-scalapack scalapack
+ libs="${intel} -lmkl_intel_thread ${core} -liomp5 -lpthread" \
+ mkl_add_prof ${prof}-intel-openmp-blacs blacs
+ libs="${scal} ${intel} -lmkl_intel_thread ${core} -liomp5 -lpthread" \
+ mkl_add_prof ${prof}-intel-openmp-scalapack scalapack
+ libs="-lmkl_rt ${blacs} -lpthread" \
+ mkl_add_prof ${prof}-dynamic-blacs blacs
+ libs="${scal} -lmkl_rt ${blacs} -lpthread" \
+ mkl_add_prof ${prof}-dynamic-scalapack scalapack
+ libs="-lmkl_rt ${blacs} -liomp5 -lpthread" \
+ mkl_add_prof ${prof}-dynamic-openmp-blacs blacs
+ libs="${scal} -lmkl_rt ${blacs} -liomp5 -lpthread" \
+ mkl_add_prof ${prof}-dynamic-openmp-scalapack scalapack
+}
+
+src_install() {
+ intel-sdp_src_install
+ echo -n > 35mkl "LDPATH="
+ for IARCH in ${INTEL_ARCH}; do
+ mkl_prof
+ sed -i -e '/mkl/s/$/:/' 35mkl
+ echo -n >> 35mkl "${INTEL_SDP_EDIR}/mkl/lib/${IARCH}"
+ [[ ${IARCH} == intel64 ]] && mkl_prof int64
+ done
+ echo >> 35mkl
+ doenvd 35mkl
+}