aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-29 20:08:09 +0200
committerJustin Lecher <jlec@gentoo.org>2010-06-29 20:08:24 +0200
commitadd2b923f9ae0dbe975aa82089231fca57d77018 (patch)
treef5b615df7e3e4c72e13fdfdaf34bb6596aacdfda
parentFix for Python ABIs (diff)
downloadsci-add2b923f9ae0dbe975aa82089231fca57d77018.tar.gz
sci-add2b923f9ae0dbe975aa82089231fca57d77018.tar.bz2
sci-add2b923f9ae0dbe975aa82089231fca57d77018.zip
Fix for Python ABIs
(Portage version: 2.2_rc67/git/Linux x86_64, RepoMan options: --force) (Signed Manifest commit)
-rw-r--r--sci-electronics/player/ChangeLog5
-rw-r--r--sci-electronics/player/Manifest14
-rw-r--r--sci-electronics/player/player-2.0.4.ebuild20
3 files changed, 28 insertions, 11 deletions
diff --git a/sci-electronics/player/ChangeLog b/sci-electronics/player/ChangeLog
index 1e685aa84..ebc001159 100644
--- a/sci-electronics/player/ChangeLog
+++ b/sci-electronics/player/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-electronics/player
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Jun 2010; Justin Lecher <jlec@gentoo.org> player-2.0.4.ebuild:
+ Python ABI fixes
+
01 Feb 2009; <elias@pipping.org>
sci-mathematics/octave-forge-octcdf/metadata.xml,
sci-mathematics/octave-forge-specfun/metadata.xml:
diff --git a/sci-electronics/player/Manifest b/sci-electronics/player/Manifest
index 26d86e2a7..0acd8127a 100644
--- a/sci-electronics/player/Manifest
+++ b/sci-electronics/player/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
DIST player-2.0.4.tar.bz2 1707996 RMD160 8b70fef48595afcf9fafe24cf57f7a3fa9ba8628 SHA1 96ae46abe9a81cab045b2a9ae6479a44fc6f2ac2 SHA256 615225f22e0585df2a5fdf9adaddbe6e2a9ca25f1015607f51a47023fcc2cdf9
-EBUILD player-2.0.4.ebuild 3253 RMD160 edc8fb1926a603955b57e306f984a114f70e512d SHA1 6cb93af4e587d91e86d4b06fae71af7f4454794c SHA256 df020fdf7e6e7c4a788e7d6746187e0a5d9be3c22d536cb303377f0eac97e9d2
-MISC ChangeLog 485 RMD160 3e0ddd3f298944ef1ef82a310156defe49ad0dc5 SHA1 798945fbaf85ca9fabb0b0895d058935e3f97873 SHA256 9aed72e4daf0be66f899615c0e128995798582e15bc7bab831ff2fc10a1b7551
+EBUILD player-2.0.4.ebuild 3280 RMD160 f34bc7231ededaa86d21e1b375f5f6bf6b392121 SHA1 ffb095227499cef9e44e14b06c01493915bc1240 SHA256 743504075e249b93799894b1097cf3d6cb0fc4cbd00120f89e1fa9bf4f551dae
+MISC ChangeLog 573 RMD160 a595645001c03bac3d7c342e54daef48d8cd2a99 SHA1 71b04000e04142100414392cebf92d57e22edcb6 SHA256 710d714facd5be6ee3c46b9d2c90dc73fa23f3e9ba4442c6821c19b5b2df4640
MISC metadata.xml 169 RMD160 c200fa2c4703eb26cf6ba49efb830c4f23678a5b SHA1 f97e1ffdd53446fb93f5b6b1225099c45337b0b4 SHA256 0b291e8666ec5ca169baa47793c8865f2f930efd84136d69b9010770a910930a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkwqNokACgkQgAnW8HDreRarJACgpdfRuf6EaOq14OarqR2zb88k
+ZGQAnRCFG7LrpVzxbWjyJIdp+p+MZLZP
+=loHm
+-----END PGP SIGNATURE-----
diff --git a/sci-electronics/player/player-2.0.4.ebuild b/sci-electronics/player/player-2.0.4.ebuild
index 235740106..37856c304 100644
--- a/sci-electronics/player/player-2.0.4.ebuild
+++ b/sci-electronics/player/player-2.0.4.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+PYTHON_DEPEND="2"
+
+inherit eutils python
DESCRIPTION="A network server for robot control"
HOMEPAGE="http://playerstage.sourceforge.net/index.php?src=player"
@@ -36,9 +38,8 @@ RDEPEND="media-libs/jpeg
openssl? ( dev-libs/openssl )
imagemagick? ( media-gfx/imagemagick )
gsl? ( sci-libs/gsl )
- python? ( dev-lang/python )
ieee1394? ( sys-libs/libraw1394 media-libs/libdc1394 )
- java? ( virtual/jdk dev-lang/python )
+ java? ( virtual/jdk )
gtk? ( x11-libs/gtk+ )
gnome? ( >=gnome-base/libgnomecanvas-2.0 )
boost? ( dev-libs/boost )
@@ -50,6 +51,9 @@ DEPEND="${RDEPEND}
java? ( dev-lang/swig )
doc? ( app-doc/doxygen )"
+pkg_setup () {
+ python_set_active_version 2
+}
src_compile() {
local drivers driver nodep_drivers
@@ -89,15 +93,15 @@ src_compile() {
$(use_enable gtk rtkgui) \
$(use_enable test tests) \
--with-playercc \
- ${drivers} || die "econf failed"
+ ${drivers}
# Parallel make will fail
emake -j1 || die "emake failed"
if use doc; then
- pushd doc
+ pushd doc > /dev/null
emake doc || die "emake doc failed"
- popd
+ popd > /dev/null
fi
}
@@ -106,7 +110,7 @@ src_install() {
if use doc; then
cd doc
- emake DESTDIR="${D}" "doc-install" || die "emake doc-install failed"
+ emake DESTDIR="${D}" doc-install || die "emake doc-install failed"
cd ..
fi