aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-12-01 12:00:25 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-12-01 12:35:26 +0800
commitc8a29b1ed68d7e9cf3af6b55f55275515d719c4f (patch)
tree2ed287430e00ecb16dbacc1824c9370558501e28
parentmedia-libs/DualContouringSample: initial commit of 0_p20191111 (diff)
downloadsci-c8a29b1ed68d7e9cf3af6b55f55275515d719c4f.tar.gz
sci-c8a29b1ed68d7e9cf3af6b55f55275515d719c4f.tar.bz2
sci-c8a29b1ed68d7e9cf3af6b55f55275515d719c4f.zip
media-libs/implicitmesher: initial commit of 0_p20191111
This is included as a dependency of sci-physics/opticks. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--media-libs/implicitmesher/files/implicitmesher-0_glm.patch34
-rw-r--r--media-libs/implicitmesher/implicitmesher-0_p20191111.ebuild29
-rw-r--r--media-libs/implicitmesher/metadata.xml7
3 files changed, 70 insertions, 0 deletions
diff --git a/media-libs/implicitmesher/files/implicitmesher-0_glm.patch b/media-libs/implicitmesher/files/implicitmesher-0_glm.patch
new file mode 100644
index 000000000..c3707e210
--- /dev/null
+++ b/media-libs/implicitmesher/files/implicitmesher-0_glm.patch
@@ -0,0 +1,34 @@
+Index: implicitmesher-0_p20191111/CMakeLists.txt
+===================================================================
+--- implicitmesher-0_p20191111.orig/CMakeLists.txt
++++ implicitmesher-0_p20191111/CMakeLists.txt
+@@ -3,19 +3,12 @@ set(name ImplicitMesher)
+ project(${name} VERSION 0.1.0)
+
+ include(CTest)
+-include(OpticksBuildOptions)
+-
+-include(GNUInstallDirs)
+-set(CMAKE_INSTALL_INCLUDEDIR "externals/include/${name}")
+-set(CMAKE_INSTALL_LIBDIR "externals/lib")
+-set(CMAKE_INSTALL_BINDIR "lib")
+-set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_FULL_LIBDIR}")
+
+ find_package(BCM REQUIRED)
+ include(BCMDeploy)
+ #include(EchoTarget)
+
+-find_package(GLM REQUIRED)
++find_package(glm REQUIRED)
+
+ set(SOURCES
+
+@@ -45,7 +38,7 @@ set(HEADERS
+ )
+
+ add_library(${name} SHARED ${SOURCES})
+-target_link_libraries(${name} PUBLIC Opticks::GLM)
++target_link_libraries(${name} PUBLIC glm)
+
+ # needed for tests that use non-installed headers
+ target_include_directories(${name} PUBLIC
diff --git a/media-libs/implicitmesher/implicitmesher-0_p20191111.ebuild b/media-libs/implicitmesher/implicitmesher-0_p20191111.ebuild
new file mode 100644
index 000000000..92156267e
--- /dev/null
+++ b/media-libs/implicitmesher/implicitmesher-0_p20191111.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mercurial cmake-utils
+
+EHG_REPO_URI="https://bitbucket.org/simoncblyth/${PN}"
+EHG_REVISION="a087394946d788bfd35a20b4b07909fa62f76a7a"
+
+DESCRIPTION="Real-time implicit surface polygonization"
+HOMEPAGE="https://bitbucket.org/simoncblyth/implicitmesher"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-libs/glm"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/implicitmesher-0_glm.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_INCLUDEDIR=include/ImplicitMesher
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/media-libs/implicitmesher/metadata.xml b/media-libs/implicitmesher/metadata.xml
new file mode 100644
index 000000000..7203fb853
--- /dev/null
+++ b/media-libs/implicitmesher/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>