aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-02-08 14:07:12 -0700
committerChristoph Junghans <ottxor@gentoo.org>2015-02-08 14:07:31 -0700
commitd70091da796cbcb5b69eafc0fa657e081b11ce92 (patch)
tree7ef6d60b8aee6a79bce2ee3c1086ab6d6d698ec3
parentsci-mathematics/why3-0.83: Cleanup ebuild (diff)
downloadsci-d70091da796cbcb5b69eafc0fa657e081b11ce92.tar.gz
sci-d70091da796cbcb5b69eafc0fa657e081b11ce92.tar.bz2
sci-d70091da796cbcb5b69eafc0fa657e081b11ce92.zip
fix bug #539318
Package-Manager: portage-2.2.14
-rw-r--r--dev-cpp/icnc/ChangeLog5
-rw-r--r--dev-cpp/icnc/icnc-9999.ebuild11
2 files changed, 11 insertions, 5 deletions
diff --git a/dev-cpp/icnc/ChangeLog b/dev-cpp/icnc/ChangeLog
index 7f3c6d539..8de9e15ef 100644
--- a/dev-cpp/icnc/ChangeLog
+++ b/dev-cpp/icnc/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for dev-cpp/icnc
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Feb 2015; Christoph Junghans <ottxor@gentoo.org> icnc-9999.ebuild:
+ fix bug #539318
+
11 Dec 2014; Christoph Junghans <ottxor@gentoo.org> icnc-9999.ebuild:
sync with upstream
diff --git a/dev-cpp/icnc/icnc-9999.ebuild b/dev-cpp/icnc/icnc-9999.ebuild
index cc650213c..5e953fa01 100644
--- a/dev-cpp/icnc/icnc-9999.ebuild
+++ b/dev-cpp/icnc/icnc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -31,6 +31,7 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
+ doc? ( app-doc/doxygen )
test? ( ${PYTHON_DEPS} )
"
@@ -38,6 +39,7 @@ src_configure() {
local mycmakeargs=(
$(cmake-utils_use mpi BUILD_LIBS_FOR_MPI)
-DLIB=$(get_libdir)
+ $(cmake-utils_use_find_package doc Doxygen)
$(cmake-utils_use test ENABLE_TESTING)
-DRUN_DIST=OFF
)
@@ -46,8 +48,9 @@ src_configure() {
src_install() {
cmake-utils_src_install
- mv "${ED}"/usr/share/{icnc/doc/api,doc/${P}/html} || die
- rmdir "${ED}"/usr/share/icnc/doc || die
- use doc || rm -r "${ED}"/usr/share/doc/${P}/html || die
+ if use doc; then
+ mv "${ED}"/usr/share/{icnc/doc/api,doc/${P}/html} || die
+ rmdir "${ED}"/usr/share/icnc/doc || die
+ fi
use examples || rm -r "${ED}"/usr/share/icnc/samples || die
}