aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2015-09-12 23:49:54 +0100
committerlayman <layman@localhost>2015-09-12 23:57:31 +0100
commitdbdead3cd3bf90ddada5b8e50d0b58596763d298 (patch)
treea6b47a9dc4d2754326bb107a8c1af5821b6a53ce
parentdev-util/nvidia-cuda-gdk: Version bump (diff)
downloadsci-dbdead3cd3bf90ddada5b8e50d0b58596763d298.tar.gz
sci-dbdead3cd3bf90ddada5b8e50d0b58596763d298.tar.bz2
sci-dbdead3cd3bf90ddada5b8e50d0b58596763d298.zip
sci-libs/rdkit: initial commit
Package-Manager: portage-2.2.20-prefix
-rw-r--r--sci-libs/rdkit/ChangeLog10
-rw-r--r--sci-libs/rdkit/Manifest1
-rw-r--r--sci-libs/rdkit/metadata.xml12
-rw-r--r--sci-libs/rdkit/rdkit-2015.03.1.ebuild47
-rw-r--r--sci-libs/rdkit/rdkit-9999.ebuild46
5 files changed, 116 insertions, 0 deletions
diff --git a/sci-libs/rdkit/ChangeLog b/sci-libs/rdkit/ChangeLog
new file mode 100644
index 000000000..8a83ba7ee
--- /dev/null
+++ b/sci-libs/rdkit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/rdkit
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Id$
+
+*rdkit-2015.03.1 (12 Sep 2015)
+*rdkit-9999 (12 Sep 2015)
+
+ 12 Sep 2015; Michael Schubert <mschu.dev@gmail.com> +metadata.xml,
+ +rdkit-2015.03.1.ebuild, +rdkit-9999.ebuild:
+ sci-libs/rdkit: initial commit
diff --git a/sci-libs/rdkit/Manifest b/sci-libs/rdkit/Manifest
new file mode 100644
index 000000000..62f50bd77
--- /dev/null
+++ b/sci-libs/rdkit/Manifest
@@ -0,0 +1 @@
+DIST rdkit-2015.03.1.tar.gz 24859988 SHA256 48da4cb234c892893b89001aeb365038a2ab5d308fd893eb2834ef2cab6b3074 SHA512 dd76bfa260e126b2e2ec59ee049ef9f4dfdb2b51c784b750148c39f26447f77f1cfe58ae0694b8286627d622447678935590724b835bab09cdb54dca4a15f386 WHIRLPOOL e0f2d6bf72fda3e76279bfa6d1e4aeb7942bf5cae30960d718732734baeaf9146bb42e29f2d110b91618aebd7419e43e94c7b5041bab64fa9bd0a12a78d1cd20
diff --git a/sci-libs/rdkit/metadata.xml b/sci-libs/rdkit/metadata.xml
new file mode 100644
index 000000000..cfa0f5016
--- /dev/null
+++ b/sci-libs/rdkit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>mschu.dev@gmail.com</email>
+ <name>Michael Schubert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rdkit/rdkit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/rdkit/rdkit-2015.03.1.ebuild b/sci-libs/rdkit/rdkit-2015.03.1.ebuild
new file mode 100644
index 000000000..e98b01784
--- /dev/null
+++ b/sci-libs/rdkit/rdkit-2015.03.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="Cheminformatics and machine-learning software written in C++ and Python"
+HOMEPAGE="http://www.rdkit.org/"
+SRC_URI="https://github.com/rdkit/rdkit/archive/Release_${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+python -static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="dev-libs/boost
+ python? (
+ dev-libs/boost[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ >=dev-db/sqlite-3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/rdkit-Release_${PV//./_}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX:PATH="${EPREFIX}"/usr
+ -DRDK_INSTALL_INTREE=0
+ -DRDK_BUILD_CPP_TESTS=OFF
+ )
+
+ if ! use static-libs; then
+ mycmakeargs+=( -DRDK_INSTALL_STATIC_LIBS=OFF )
+ fi
+
+ if ! use python; then
+ mycmakeargs+=( RDK_BUILD_PYTHON_WRAPPERS= )
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/rdkit/rdkit-9999.ebuild b/sci-libs/rdkit/rdkit-9999.ebuild
new file mode 100644
index 000000000..dfa196f5b
--- /dev/null
+++ b/sci-libs/rdkit/rdkit-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit cmake-utils python-r1 git-r3
+
+DESCRIPTION="Cheminformatics and machine-learning software written in C++ and Python"
+HOMEPAGE="http://www.rdkit.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/rdkit/rdkit.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+python -static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="dev-libs/boost
+ python? (
+ dev-libs/boost[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ >=dev-db/sqlite-3"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX:PATH="${EPREFIX}"/usr
+ -DRDK_INSTALL_INTREE=0
+ -DRDK_BUILD_CPP_TESTS=OFF
+ )
+
+ if ! use static-libs; then
+ mycmakeargs+=( -DRDK_INSTALL_STATIC_LIBS=OFF )
+ fi
+
+ if ! use python; then
+ mycmakeargs+=( RDK_BUILD_PYTHON_WRAPPERS= )
+ fi
+
+ cmake-utils_src_configure
+}