aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelte Fennema <github-tech@jeltef.nl>2014-06-14 16:10:11 +0200
committerJelte Fennema <github-tech@jeltef.nl>2014-06-14 16:10:11 +0200
commit7ae1d96cee5e9375c8b0f4df7ef4584dc3403872 (patch)
tree44e63012108a9828f4726a140943a466569297a5 /app-editors/neovim/neovim-9999.ebuild
parentsci-chemistry/openbabel-python: Update PYTHON_COMPAT (diff)
downloadsci-7ae1d96cee5e9375c8b0f4df7ef4584dc3403872.tar.gz
sci-7ae1d96cee5e9375c8b0f4df7ef4584dc3403872.tar.bz2
sci-7ae1d96cee5e9375c8b0f4df7ef4584dc3403872.zip
Use CFLAGS needed to get a working executable
Package-Manager: portage-2.2.10
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 4b53e5768..dee1bc58d 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="git://github.com/neovim/neovim.git"
@@ -23,6 +23,11 @@ SLOT="0"
KEYWORDS=""
IUSE=""
+src_configure() {
+ append-flags "-DNDEBUG -Wno-error -D_FORTIFY_SOURCE=1"
+ cmake-utils_src_configure
+}
+
RDEPEND="app-admin/eselect-vi
sys-libs/ncurses"
DEPEND="${RDEPEND}