aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-25 17:54:01 +0200
committerJustin Lecher <jlec@gentoo.org>2012-10-25 17:54:01 +0200
commit523e75bce6f5acc7354ae8a4e09d270d6570137e (patch)
tree6fcc781c4704223ec2f97c2bc0251e444c05bb73 /dev-cpp/eigen
parentUpdate M2 live ebuild (diff)
downloadsci-523e75bce6f5acc7354ae8a4e09d270d6570137e.tar.gz
sci-523e75bce6f5acc7354ae8a4e09d270d6570137e.tar.bz2
sci-523e75bce6f5acc7354ae8a4e09d270d6570137e.zip
dev-cpp/eigen: Use vcs-snapshot.eclass, correct usage of fortran-2.eclass, some layout improvements
Package-Manager: portage-2.2.0_alpha141
Diffstat (limited to 'dev-cpp/eigen')
-rw-r--r--dev-cpp/eigen/ChangeLog5
-rw-r--r--dev-cpp/eigen/eigen-3.0.6-r1.ebuild37
-rw-r--r--dev-cpp/eigen/eigen-9999.ebuild34
-rw-r--r--dev-cpp/eigen/metadata.xml15
4 files changed, 48 insertions, 43 deletions
diff --git a/dev-cpp/eigen/ChangeLog b/dev-cpp/eigen/ChangeLog
index 595a02db0..471649a8f 100644
--- a/dev-cpp/eigen/ChangeLog
+++ b/dev-cpp/eigen/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-cpp/eigen/ChangeLog,v 1.44 2011/03/25 16:01:28 jlec Exp $
+ 25 Oct 2012; Justin Lecher <jlec@gentoo.org> eigen-3.0.6-r1.ebuild,
+ eigen-9999.ebuild, metadata.xml:
+ Use vcs-snapshot.eclass, correct usage of fortran-2.eclass, some layout
+ improvements
+
*eigen-3.1.1-r1 (26 Jul 2012)
26 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +eigen-3.1.1-r1.ebuild,
diff --git a/dev-cpp/eigen/eigen-3.0.6-r1.ebuild b/dev-cpp/eigen/eigen-3.0.6-r1.ebuild
index c98fb2ec1..1ad9b1556 100644
--- a/dev-cpp/eigen/eigen-3.0.6-r1.ebuild
+++ b/dev-cpp/eigen/eigen-3.0.6-r1.ebuild
@@ -4,39 +4,37 @@
EAPI=4
-inherit cmake-utils alternatives-2 fortran-2 multilib
+FORTRAN_NEEDED=fortran
+
+inherit alternatives-2 cmake-utils fortran-2 multilib vcs-snapshot
DESCRIPTION="C++ template library for linear algebra"
HOMEPAGE="http://eigen.tuxfamily.org/"
SRC_URI="http://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+SLOT="3"
LICENSE="|| ( LGPL-3 GPL-2 )"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="3"
IUSE="adolc fortran fftw doc gmp sparse static-libs test"
-CDEPEND="adolc? ( sci-libs/adolc[sparse?] )
+CDEPEND="
+ adolc? ( sci-libs/adolc[sparse?] )
fftw? ( >=sci-libs/fftw-3 )
gmp? ( dev-libs/gmp dev-libs/mpfr )
- sparse? ( dev-cpp/sparsehash
- sci-libs/cholmod[metis]
- sci-libs/superlu
- sci-libs/umfpack )"
+ sparse? (
+ dev-cpp/sparsehash
+ sci-libs/cholmod[metis]
+ sci-libs/superlu
+ sci-libs/umfpack
+ )"
-DEPEND="doc? ( app-doc/doxygen[dot,latex] )
+DEPEND="
+ doc? ( app-doc/doxygen[dot,latex] )
test? ( ${CDEPEND} )"
-
-RDEPEND="!dev-cpp/eigen:0
+RDEPEND="
+ !dev-cpp/eigen:0
${CDEPEND}"
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
-}
-
-src_unpack() {
- unpack ${A} && mv ${PN}* ${P}
-}
-
src_configure() {
# TOFIX: static-libs for blas are always built with PIC
# TOFIX: is it worth fixing all the automagic given no library is built?
@@ -46,7 +44,8 @@ src_configure() {
$(cmake-utils_use !fortran EIGEN_TEST_NO_FORTRAN)
)
CMAKE_BUILD_TYPE="release" cmake-utils_src_configure
- use fortran && FORTRAN_LIBS="blas" # lapack not ready yet
+ # lapack not ready yet?
+ use fortran && FORTRAN_LIBS="blas"
}
src_compile() {
diff --git a/dev-cpp/eigen/eigen-9999.ebuild b/dev-cpp/eigen/eigen-9999.ebuild
index 973ffbfa0..9d52cff4f 100644
--- a/dev-cpp/eigen/eigen-9999.ebuild
+++ b/dev-cpp/eigen/eigen-9999.ebuild
@@ -4,6 +4,8 @@
EAPI=4
+FORTRAN_NEEDED=fortran
+
if [[ ${PV} == "9999" ]] ; then
_SCM=mercurial
EHG_REPO_URI="https://bitbucket.org/eigen/eigen"
@@ -14,40 +16,36 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit cmake-utils alternatives-2 fortran-2 multilib ${_SCM}
+inherit alternatives-2 cmake-utils fortran-2 multilib vcs-snapshot ${_SCM}
DESCRIPTION="C++ template library for linear algebra"
HOMEPAGE="http://eigen.tuxfamily.org/"
-LICENSE="MPL-2.0"
SLOT="3"
+LICENSE="MPL-2.0"
IUSE="adolc doc fortran fftw gmp mkl sparse static-libs test"
# TODO: support for pastix
-CDEPEND="adolc? ( sci-libs/adolc[sparse?] )
- fortran? ( virtual/fortran )
+CDEPEND="
+ adolc? ( sci-libs/adolc[sparse?] )
fftw? ( >=sci-libs/fftw-3 )
gmp? ( dev-libs/gmp dev-libs/mpfr )
mkl? ( sci-libs/mkl )
- sparse? ( dev-cpp/sparsehash
- sci-libs/cholmod[metis]
- sci-libs/superlu
- sci-libs/umfpack )"
+ sparse? (
+ dev-cpp/sparsehash
+ sci-libs/cholmod[metis]
+ sci-libs/superlu
+ sci-libs/umfpack
+ )"
-DEPEND="doc? ( app-doc/doxygen[dot,latex] )
+DEPEND="
+ doc? ( app-doc/doxygen[dot,latex] )
test? ( ${CDEPEND} )"
-RDEPEND="!dev-cpp/eigen:0
+RDEPEND="
+ !dev-cpp/eigen:0
${CDEPEND}"
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
-}
-
-src_unpack() {
- unpack ${A} && mv ${PN}* ${P}
-}
-
src_configure() {
# TOFIX: static-libs for blas are always built with PIC
# TOFIX: is it worth fixing all the automagic given no library is built?
diff --git a/dev-cpp/eigen/metadata.xml b/dev-cpp/eigen/metadata.xml
index 6e9235c8b..bb9ba2f9e 100644
--- a/dev-cpp/eigen/metadata.xml
+++ b/dev-cpp/eigen/metadata.xml
@@ -1,20 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
Eigen is a lightweight C++ template library for vector and matrix math,
a.k.a. linear algebra. Unlike most other linear algebra libraries, Eigen
focuses on the simple mathematical needs of applications: games and other
OpenGL apps, spreadsheets and other office apps, etc. Eigen is dedicated to
providing optimal speed with GCC.
</longdescription>
-<use>
- <flag name="adolc">
+ <use>
+ <flag name="adolc">
Enable use for automatic differentiation using <pkg>sci-libs/adolc</pkg>
</flag>
- <flag name="sparse">
+ <flag name="mkl">
+ Use propertary intel blas/lapack implementation through <pkg>sci-libs/mkl</pkg>
+ </flag>
+ <flag name="sparse">
Enable use for extra sparse matrix with <pkg>sci-libs/umfpack</pkg>, <pkg>sci-libs/cholmod</pkg>, <pkg>sci-libs/superlu</pkg> and <pkg>dev-cpp/sparsehash</pkg>
</flag>
-</use>
+ </use>
</pkgmetadata>