aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-01-12 00:26:50 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-01-12 00:26:50 +0100
commit6e6616f8521d20074bbca6522e2a5570718d5736 (patch)
tree6c5fb85d5a21ee2bc9eaa05f1b2629f0772f3d75 /dev-java/htsjdk
parentsci-biology/picard-2.8.1: version bump, do not compile tests by default (diff)
downloadsci-6e6616f8521d20074bbca6522e2a5570718d5736.tar.gz
sci-6e6616f8521d20074bbca6522e2a5570718d5736.tar.bz2
sci-6e6616f8521d20074bbca6522e2a5570718d5736.zip
dev-java/htsjdk: add a live ebuild, add a note
Not sure if current build system still creates $HOME/.git but from reading github Issues it seem it is still needed: users are even asked to run 'git clone' to work around the issue when gradle fails to do that. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-java/htsjdk')
-rw-r--r--dev-java/htsjdk/htsjdk-2.5.1.ebuild4
-rw-r--r--dev-java/htsjdk/htsjdk-9999.ebuild53
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-java/htsjdk/htsjdk-2.5.1.ebuild b/dev-java/htsjdk/htsjdk-2.5.1.ebuild
index 0f1e162dd..6ba163f80 100644
--- a/dev-java/htsjdk/htsjdk-2.5.1.ebuild
+++ b/dev-java/htsjdk/htsjdk-2.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,7 +36,7 @@ java_prepare(){
}
src_compile(){
- # work around gradle writing $HOME/.gradle
+ # work around gradle writing $HOME/.gradle and $HOME/.git
# https://github.com/samtools/htsjdk/issues/660#issuecomment-232155965
GRADLE_USER_HOME="${WORKDIR}" ./gradlew build || die
}
diff --git a/dev-java/htsjdk/htsjdk-9999.ebuild b/dev-java/htsjdk/htsjdk-9999.ebuild
new file mode 100644
index 000000000..e9576743a
--- /dev/null
+++ b/dev-java/htsjdk/htsjdk-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit git-r3 java-pkg-2 java-ant-2
+
+DESCRIPTION="Java API for high-throughput sequencing data (HTS) formats."
+HOMEPAGE="https://samtools.github.io/htsjdk/"
+EGIT_REPO_URI="https://github.com/samtools/htsjdk.git"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="" # SANDBOX VIOLATION
+
+CDEPEND="dev-java/commons-jexl:2
+ dev-java/commons-compress:0
+ dev-java/commons-logging:0"
+
+DEPEND=">=virtual/jdk-1.8
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.8
+ ${CDEPEND}"
+
+EANT_BUILD_TARGET="all"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="commons-jexl-2,commons-compress,commons-logging"
+
+java_prepare(){
+ default
+}
+
+src_compile(){
+ # work around gradle writing $HOME/.gradle and $HOME/.git
+ # https://github.com/samtools/htsjdk/issues/660#issuecomment-232155965
+ GRADLE_USER_HOME="${WORKDIR}" ./gradlew || die
+}
+
+src_install() {
+ cd build/libs || die
+
+ #for i in *-SNAPSHOT.jar; do
+ # java-pkg_newjar $i ${i/-[0-9]*.jar/.jar}
+ #done
+ java-pkg_newjar "${S}"/build/libs/*-SNAPSHOT.jar htsjdk.jar
+ use source && java-pkg_dosrc "${S}"/build/libs/*-sources.jar
+ use doc && java-pkg_dojavadoc "${S}"/build/libs/*-javadoc.jar
+}