aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2010-01-22 18:33:29 +0000
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2010-01-22 18:33:29 +0000
commit1c109000c4d979a7bcb36c23dec5a4ae01a8d560 (patch)
treea2a1a24edcfc3cd2205cdff0d9307a02df79b0b8 /dev-java/jlatexmath/jlatexmath-0.8.7.ebuild
parentmove EGIT stuff up before inherit (diff)
downloadsci-1c109000c4d979a7bcb36c23dec5a4ae01a8d560.tar.gz
sci-1c109000c4d979a7bcb36c23dec5a4ae01a8d560.tar.bz2
sci-1c109000c4d979a7bcb36c23dec5a4ae01a8d560.zip
Initial import of hdf-java
Diffstat (limited to 'dev-java/jlatexmath/jlatexmath-0.8.7.ebuild')
-rw-r--r--dev-java/jlatexmath/jlatexmath-0.8.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/jlatexmath/jlatexmath-0.8.7.ebuild b/dev-java/jlatexmath/jlatexmath-0.8.7.ebuild
new file mode 100644
index 000000000..a41649286
--- /dev/null
+++ b/dev-java/jlatexmath/jlatexmath-0.8.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java API to render LaTeX"
+SRC_URI="http://forge.scilab.org/index.php/p/${PN}/downloads/29/get/ -> ${PN}-src-${PV}.jar"
+HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
+
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+EANT_BUILD_TARGET="buildJar"
+EANT_DOC_TARGET="doc"
+
+S="${WORKDIR}"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/org
+}