aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2013-06-02 01:50:58 +0200
committerAndreas Schäfer <gentryx@gmx.de>2013-06-02 01:50:58 +0200
commitef384cac819c5b160afaae5e98f8bc0a0634c37a (patch)
tree527a6b51b93ea2d5a7e6f6e178949a573822b15f /dev-lang
parentadded PGI ebuild (diff)
downloadsci-ef384cac819c5b160afaae5e98f8bc0a0634c37a.tar.gz
sci-ef384cac819c5b160afaae5e98f8bc0a0634c37a.tar.bz2
sci-ef384cac819c5b160afaae5e98f8bc0a0634c37a.zip
added fix for recent glibc with PGI
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/pgi/files/glibc.patch31
-rw-r--r--dev-lang/pgi/pgi-13.5.ebuild2
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-lang/pgi/files/glibc.patch b/dev-lang/pgi/files/glibc.patch
new file mode 100644
index 000000000..434f12cb5
--- /dev/null
+++ b/dev-lang/pgi/files/glibc.patch
@@ -0,0 +1,31 @@
+diff -ru opt/pgi/linux86/13.5/include/bits/types.h opt/pgi-b/linux86/13.5/include/bits/types.h
+--- opt/pgi/linux86/13.5/include/bits/types.h 2013-05-07 21:45:39.000000000 +0200
++++ opt/pgi-b/linux86/13.5/include/bits/types.h 2013-06-02 01:24:19.000000000 +0200
+@@ -136,6 +136,7 @@
+ #include <bits/typesizes.h> /* Defines __*_T_TYPE macros. */
+
+
++__STD_TYPE __SQUAD_TYPE __syscall_slong_t;
+ __STD_TYPE __DEV_T_TYPE __dev_t; /* Type of device numbers. */
+ __STD_TYPE __UID_T_TYPE __uid_t; /* Type of user identifications. */
+ __STD_TYPE __GID_T_TYPE __gid_t; /* Type of group identifications. */
+diff -ru opt/pgi/linux86-64/13.5/include/bits/types.h opt/pgi-b/linux86-64/13.5/include/bits/types.h
+--- opt/pgi/linux86-64/13.5/include/bits/types.h 2013-05-07 21:45:39.000000000 +0200
++++ opt/pgi-b/linux86-64/13.5/include/bits/types.h 2013-06-02 01:23:51.000000000 +0200
+@@ -135,7 +135,7 @@
+ #endif
+ #include <bits/typesizes.h> /* Defines __*_T_TYPE macros. */
+
+-
++__STD_TYPE __SQUAD_TYPE __syscall_slong_t;
+ __STD_TYPE __DEV_T_TYPE __dev_t; /* Type of device numbers. */
+ __STD_TYPE __UID_T_TYPE __uid_t; /* Type of user identifications. */
+ __STD_TYPE __GID_T_TYPE __gid_t; /* Type of group identifications. */
+@@ -156,7 +156,6 @@
+ __STD_TYPE __SUSECONDS_T_TYPE __suseconds_t; /* Signed count of microseconds. */
+
+ __STD_TYPE __DADDR_T_TYPE __daddr_t; /* The type of a disk address. */
+-__STD_TYPE __SWBLK_T_TYPE __swblk_t; /* Type of a swap block maybe? */
+ __STD_TYPE __KEY_T_TYPE __key_t; /* Type of an IPC key. */
+
+ /* Clock ID used in clock and timer functions. */
diff --git a/dev-lang/pgi/pgi-13.5.ebuild b/dev-lang/pgi/pgi-13.5.ebuild
index 8468e96c1..354b996b6 100644
--- a/dev-lang/pgi/pgi-13.5.ebuild
+++ b/dev-lang/pgi/pgi-13.5.ebuild
@@ -51,6 +51,7 @@ pkg_nofetch() {
src_prepare() {
epatch "${FILESDIR}/terminal.patch"
+ echo "andi ${FILESDIR}"
}
src_install() {
@@ -97,4 +98,5 @@ y
./install <<EOF
${command}
EOF
+ patch -p0 <"${FILESDIR}/glibc.patch"
}