aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-16 11:10:10 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-09-16 11:10:10 +0200
commit27e77ad519c3d49a3c04c21896cd678c73e2a150 (patch)
tree14e48c474417b3369dd249db1aa729619a72e588 /dev-python/arrayfire-python/arrayfire-python-9999.ebuild
parentsci-chemistry/coot: Fix PYTHONPATH during test (diff)
downloadsci-27e77ad519c3d49a3c04c21896cd678c73e2a150.tar.gz
sci-27e77ad519c3d49a3c04c21896cd678c73e2a150.tar.bz2
sci-27e77ad519c3d49a3c04c21896cd678c73e2a150.zip
dev-python/arrayfire-python: New package, ebuild wirtten by me
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/arrayfire-python/arrayfire-python-9999.ebuild')
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/arrayfire-python/arrayfire-python-9999.ebuild b/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
new file mode 100644
index 000000000..c4d561b8d
--- /dev/null
+++ b/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ArrayFire"
+HOMEPAGE="http://www.arrayfire.com"
+
+MY_PN="arrayfire"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arrayfire/${PN}.git git://github.com/arrayfire/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=sci-libs/arrayfire-3.0.0
+ "
+DEPEND="${RDEPEND}"