aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-25 13:02:01 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-25 13:02:01 +0000
commit9b472b90d48655a31d2d20606d7bdac37297a2e0 (patch)
tree10df8ab67240deabac732ffb1b25f85b1331e6c6 /dev-python/arrayfire-python
parentdev-python/arrayfire-python: drop old versions (diff)
downloadsci-9b472b90d48655a31d2d20606d7bdac37297a2e0.tar.gz
sci-9b472b90d48655a31d2d20606d7bdac37297a2e0.tar.bz2
sci-9b472b90d48655a31d2d20606d7bdac37297a2e0.zip
dev-python/arrayfire-python: version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python/arrayfire-python')
-rw-r--r--dev-python/arrayfire-python/Manifest3
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-3.4.20170222.ebuild26
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild35
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-3.6.20181017_p1.ebuild39
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-9999.ebuild19
-rw-r--r--dev-python/arrayfire-python/files/arrayfire-python-3.6.20181017_p1-skip_tests.patch20
6 files changed, 96 insertions, 46 deletions
diff --git a/dev-python/arrayfire-python/Manifest b/dev-python/arrayfire-python/Manifest
index 839fb82be..6d077c449 100644
--- a/dev-python/arrayfire-python/Manifest
+++ b/dev-python/arrayfire-python/Manifest
@@ -1 +1,2 @@
-DIST arrayfire-python-3.4.20170222.tar.gz 111992 BLAKE2B a2540341cd900c7edfe07ae7beea3c61e5b6ee13effd87fb9450ecf338c99146f4077ebf2c8032ee284f7a2b8ba546a055eefbeb670a028081ad87914fb56f3f SHA512 a9c41c7932592df15a023c41d920bd9588da55a58db456d42e2c5b707645564c48aef26ae99345cae8053585a55a4b85b26750e998f2873f81b5d068afe29f71
+DIST arrayfire-python-3.6.20181017.tar.gz 115659 BLAKE2B a58f8a3e929b9b04a7ce4339624833a9bcf513c790e6bf66edabaaeb01b590d651d6a89584ccf04387e9844dc506b1d21ea3392a2b6361802404820c1ff9d91a SHA512 8ae9d0c3e4b27ff237c47a55358ab6421eef4a3d251583e8d64b48ff40a8b9e6773e6fc27473c228141a5c9be86ba096bacd8ee1716d2f82f5dd97440b87bec4
+DIST arrayfire-python-3.6.20181017_p1.tar.gz 126376 BLAKE2B 33699c33a12a9231baac11a462502dbda2eb0e743256b7d4bff0b9b0925652efa9504ed5dc123b86493b7751bed85cd4050807297da087fe765dbc44ba985520 SHA512 2977365f7817528cf0c73fe0c21704efba9c5b30b902a5b3449ed6b4487492ed1baa2a60c03b42087232d8a119f5a0b0af9aa16cf8d83a05092c0eb78fa8e147
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.4.20170222.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.4.20170222.ebuild
deleted file mode 100644
index 32818eef8..000000000
--- a/dev-python/arrayfire-python/arrayfire-python-3.4.20170222.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for ArrayFire"
-HOMEPAGE="http://www.arrayfire.com"
-SRC_URI="https://github.com/arrayfire/arrayfire-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=sci-libs/arrayfire-3.4.0
- <sci-libs/arrayfire-3.5.0
- "
-DEPEND="${RDEPEND}"
-
-python_test() {
- ${EPYTHON} -m arrayfire.tests
-}
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild
new file mode 100644
index 000000000..8c5542a86
--- /dev/null
+++ b/dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ArrayFire"
+HOMEPAGE="http://www.arrayfire.com"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arrayfire/arrayfire-python"
+else
+ SRC_URI="https://github.com/arrayfire/arrayfire-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-libs/arrayfire
+"
+DEPEND="${RDEPEND}"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ ${EPYTHON} -m arrayfire.tests || \
+ die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.6.20181017_p1.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.6.20181017_p1.ebuild
new file mode 100644
index 000000000..0dd4a4434
--- /dev/null
+++ b/dev-python/arrayfire-python/arrayfire-python-3.6.20181017_p1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ArrayFire"
+HOMEPAGE="http://www.arrayfire.com"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arrayfire/arrayfire-python"
+else
+ COMMIT=534b8c2ab4db5b08347f4d3d2f86a58ba8fcfdb6
+ SRC_URI="https://github.com/arrayfire/arrayfire-python/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-libs/arrayfire
+"
+DEPEND="${RDEPEND}"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${P}-skip_tests.patch )
+
+python_test() {
+ ${EPYTHON} -m tests || \
+ die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/arrayfire-python/arrayfire-python-9999.ebuild b/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
deleted file mode 100644
index 5704d5093..000000000
--- a/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Python bindings for ArrayFire"
-HOMEPAGE="http://www.arrayfire.com"
-EGIT_REPO_URI="https://github.com/arrayfire/${PN}.git git://github.com/arrayfire/${PN}.git"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="
- >=sci-libs/arrayfire-3.0.0
- "
-DEPEND="${RDEPEND}"
diff --git a/dev-python/arrayfire-python/files/arrayfire-python-3.6.20181017_p1-skip_tests.patch b/dev-python/arrayfire-python/files/arrayfire-python-3.6.20181017_p1-skip_tests.patch
new file mode 100644
index 000000000..eb4eb54cf
--- /dev/null
+++ b/dev-python/arrayfire-python/files/arrayfire-python-3.6.20181017_p1-skip_tests.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/simple/__init__.py b/tests/simple/__init__.py
+index 4950136..41c9cf2 100644
+--- a/tests/simple/__init__.py
++++ b/tests/simple/__init__.py
+@@ -11,7 +11,6 @@
+
+ from ._util import tests
+ from .algorithm import simple_algorithm
+-from .arith import simple_arith
+ from .array_test import simple_array
+ from .blas import simple_blas
+ from .data import simple_data
+@@ -28,7 +27,6 @@ from .statistics import simple_statistics
+ __all__ = [
+ "tests",
+ "simple_algorithm",
+- "simple_arith",
+ "simple_array",
+ "simple_blas",
+ "simple_data",