aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-09-27 22:34:55 -0400
committerHorea Christian <chr@chymera.eu>2022-09-27 22:34:55 -0400
commit355ac09d51851dcaca6913ec93ecfcb4c795be74 (patch)
treeea4b8ac7eee12c617c967b83bad0237d8a758954 /dev-python/nwbinspector/nwbinspector-0.4.14.ebuild
parentnet-misc/cernbox-client: drop 2.10.0.6519 (diff)
downloadsci-355ac09d51851dcaca6913ec93ecfcb4c795be74.tar.gz
sci-355ac09d51851dcaca6913ec93ecfcb4c795be74.tar.bz2
sci-355ac09d51851dcaca6913ec93ecfcb4c795be74.zip
dev-python/nwbinspector: add 0.4.14
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/nwbinspector/nwbinspector-0.4.14.ebuild')
-rw-r--r--dev-python/nwbinspector/nwbinspector-0.4.14.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild b/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild
new file mode 100644
index 000000000..a2b20f5af
--- /dev/null
+++ b/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Inspect NWB files for compliance with NWB Best Practices"
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/nwbinspector"
+SRC_URI="https://github.com/NeurodataWithoutBorders/nwbinspector/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_inspector.py
+ tests/unit_tests/test_time_series.py
+ )
+ epytest
+}