aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-04 12:17:30 +0100
committerHorea Christian <chr@chymera.eu>2021-01-05 02:38:31 -0500
commit4de1a2e8ea2a0891b199ee4a7ae3368b37cb9ac8 (patch)
treeeffdbfb9d744bf85293487148ce562624b216585 /dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild
parentReadme.md: typo (diff)
downloadsci-4de1a2e8ea2a0891b199ee4a7ae3368b37cb9ac8.tar.gz
sci-4de1a2e8ea2a0891b199ee4a7ae3368b37cb9ac8.tar.bz2
sci-4de1a2e8ea2a0891b199ee4a7ae3368b37cb9ac8.zip
dev-python/pytest-doctestplus: new dep
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild')
-rw-r--r--dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild b/dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild
new file mode 100644
index 000000000..05b962262
--- /dev/null
+++ b/dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin with advanced doctest features"
+HOMEPAGE="https://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# TODO: fix this
+RESTRICT="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest