aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-30 17:28:38 +0100
committerAisha Tammy <gentoo@aisha.cc>2020-12-31 17:22:01 +0000
commitc9d924c16cd035cbbb89e4a813d33666075eebc7 (patch)
tree05bcd98a1762467c94ad1f78d51b5a727bf00691 /dev-python
parentdev-python/toposort: new dep (diff)
downloadsci-c9d924c16cd035cbbb89e4a813d33666075eebc7.tar.gz
sci-c9d924c16cd035cbbb89e4a813d33666075eebc7.tar.bz2
sci-c9d924c16cd035cbbb89e4a813d33666075eebc7.zip
dev-python/datrie: new dep
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/datrie/Manifest1
-rw-r--r--dev-python/datrie/datrie-0.8.2.ebuild31
-rw-r--r--dev-python/datrie/metadata.xml12
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/datrie/Manifest b/dev-python/datrie/Manifest
new file mode 100644
index 000000000..2214acc5c
--- /dev/null
+++ b/dev-python/datrie/Manifest
@@ -0,0 +1 @@
+DIST datrie-0.8.2.tar.gz 63278 BLAKE2B 1f58058900c8987ace02d09b893c7df677cdbf7d17d77a2dca8b40f8f6b87d3ddd66b2bda9433afaf092d841e7025d628078976fbd85de469328d013d357db70 SHA512 db1aaa5c50fa4fb6f8abb80200b4b68b05b42e490364b63576492c44ae4208867cbd0ef0dd64ff5a932c6462cd60f41f339d85ac58ade47ef34d34f4f1cf68c6
diff --git a/dev-python/datrie/datrie-0.8.2.ebuild b/dev-python/datrie/datrie-0.8.2.ebuild
new file mode 100644
index 000000000..de547910d
--- /dev/null
+++ b/dev-python/datrie/datrie-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="https://gitlab.com/ericvsmith/toposort"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not depend on pytest-runner
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/datrie/metadata.xml b/dev-python/datrie/metadata.xml
new file mode 100644
index 000000000..a399a3d31
--- /dev/null
+++ b/dev-python/datrie/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pytries/datrie</remote-id>
+ <remote-id type="pypi">datrie</remote-id>
+ </upstream>
+</pkgmetadata>