aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 18:41:47 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 18:41:47 +0100
commitd46b77aebc1c74e9cb9266ce5212b7d7589c8557 (patch)
tree0f0df01c20fe990b6a36855f81a3af92eceb9edf /dev-python
parentdev-python/reproject: bump to 0.8 (diff)
downloadsci-d46b77aebc1c74e9cb9266ce5212b7d7589c8557.tar.gz
sci-d46b77aebc1c74e9cb9266ce5212b7d7589c8557.tar.bz2
sci-d46b77aebc1c74e9cb9266ce5212b7d7589c8557.zip
dev-python/meshio: add version 5.3.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/meshio/Manifest1
-rw-r--r--dev-python/meshio/meshio-5.3.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/meshio/Manifest b/dev-python/meshio/Manifest
index 191a8e4aa..782761865 100644
--- a/dev-python/meshio/Manifest
+++ b/dev-python/meshio/Manifest
@@ -1 +1,2 @@
DIST meshio-4.4.6.tar.gz 482071 BLAKE2B f8d410ad7293b5e7f9debbb1e4dc9050304731bee1091b4480aeace006a92bb8f7cec2fc442d0f5b20d492ae859bb76cbb52b6be26f06be2558bc42a27d9cd96 SHA512 624f551b017b6c4e44efc5db0fb6d08a161ceef64d1317264eaf3ba0f36202b93c3fa959ab34ce8212c01083ae570b3db25c7445eee2d51feaf84726984e2770
+DIST meshio-5.3.0.tar.gz 491246 BLAKE2B 0fd867c2ddabb29cd88dfdea1b5ef04ebf8d63ed957df5df7c426a00f0de409dcd556de4530dec91e71126671e7048af071f734e3d1c375fc67de0403edd7f37 SHA512 2304c75b74093120655cbfae6ec7b770de6bfdbe677c84e997449df91d7d3fd6b61c946d00bf57eba99e5812a08a032c55bf2d4c81316b356016d818b329f795
diff --git a/dev-python/meshio/meshio-5.3.0.ebuild b/dev-python/meshio/meshio-5.3.0.ebuild
new file mode 100644
index 000000000..0a97aaf69
--- /dev/null
+++ b/dev-python/meshio/meshio-5.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python input/output for many mesh formats"
+HOMEPAGE="https://pypi.org/project/meshio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/netcdf4-python[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest