aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-23 08:38:28 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-09-23 08:38:28 +0200
commitd4eea6844d07b4bacd9354ba58c25709cc21958a (patch)
treeebb1ef0f3a621c927b4fe71eec166f0bd11c411c /dev-python
parentwww-client/casperjs: Fix 'Invalid Gentoo/GPL License on line' (diff)
downloadsci-d4eea6844d07b4bacd9354ba58c25709cc21958a.tar.gz
sci-d4eea6844d07b4bacd9354ba58c25709cc21958a.tar.bz2
sci-d4eea6844d07b4bacd9354ba58c25709cc21958a.zip
dev-python/nbconvert: Replace symlink
Diffstat (limited to 'dev-python')
-rw-r--r--[l---------]dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild79
-rw-r--r--dev-python/nbconvert/nbconvert-9999.ebuild15
2 files changed, 82 insertions, 12 deletions
diff --git a/dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild b/dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild
index ac4dd4146..9e298f39c 120000..100644
--- a/dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild
+++ b/dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild
@@ -1 +1,78 @@
-nbconvert-9999.ebuild \ No newline at end of file
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="nbconvert"
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-docs-Makefile.patch
+ "${FILESDIR}/${P}"-pandoc-highlighting.patch
+)
+
+RDEPEND="
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/mistune[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ app-text/pandoc
+ )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ nosetests --with-coverage --cover-package=nbconvert nbconvert || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc ; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc."
+ fi
+}
diff --git a/dev-python/nbconvert/nbconvert-9999.ebuild b/dev-python/nbconvert/nbconvert-9999.ebuild
index 297f7bf04..c97ed8a75 100644
--- a/dev-python/nbconvert/nbconvert-9999.ebuild
+++ b/dev-python/nbconvert/nbconvert-9999.ebuild
@@ -5,27 +5,20 @@
EAPI=5
PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 git-r3
MY_PN="nbconvert"
DESCRIPTION="Converting Jupyter Notebooks"
HOMEPAGE="http://jupyter.org"
-
-PATCHES=( "${FILESDIR}/${PN}"-4.0.0-docs-Makefile.patch )
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/jupyter/${MY_PN}.git git://github.com/jupyter/${MY_PN}.git"
- else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- PATCHES+=( "${FILESDIR}"/${P}-pandoc-highlighting.patch )
-fi
+EGIT_REPO_URI="https://github.com/jupyter/${MY_PN}.git git://github.com/jupyter/${MY_PN}.git"
LICENSE="BSD"
SLOT="0"
IUSE="doc test"
+PATCHES=( "${FILESDIR}/${PN}"-4.0.0-docs-Makefile.patch )
+
RDEPEND="
dev-python/jupyter_core[${PYTHON_USEDEP}]
dev-python/nbformat[${PYTHON_USEDEP}]