aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 18:28:18 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 18:28:18 +0100
commiteb4a8f36f0fb38edb233b100b56f410aad3a8a1d (patch)
tree9277fe6e3d4857dec1cb8e24f12498dc92b3907b /dev-python
parentdev-python/meshpy: bump to 2020.1 (diff)
downloadsci-eb4a8f36f0fb38edb233b100b56f410aad3a8a1d.tar.gz
sci-eb4a8f36f0fb38edb233b100b56f410aad3a8a1d.tar.bz2
sci-eb4a8f36f0fb38edb233b100b56f410aad3a8a1d.zip
dev-python/python-igraph: drop old
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-igraph/Manifest2
-rw-r--r--dev-python/python-igraph/python-igraph-0.8.2.ebuild36
-rw-r--r--dev-python/python-igraph/python-igraph-0.8.3.ebuild36
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/python-igraph/Manifest b/dev-python/python-igraph/Manifest
index e8ec2f978..bb22f152b 100644
--- a/dev-python/python-igraph/Manifest
+++ b/dev-python/python-igraph/Manifest
@@ -1,3 +1 @@
-DIST python-igraph-0.8.2.tar.gz 3970354 BLAKE2B 2107a147ad98fa0b1a6c4f7332167a4256225615b9ef457e7c4b39c63cbe97456b4952e7c208ab0712365e1103eb541f4f8d0f0554470132b05b57bcc8f1dc67 SHA512 669d44081de2f0e1d0ef5b06e1cced193a9a0686e3e5e58b8334fd6eef14df3226cd0f7902f88289e575c822516e85b442c89ca9ec73a0d9d48ac8522347a30a
-DIST python-igraph-0.8.3.tar.gz 4059460 BLAKE2B 795dee8a72450c8d6ccf88188f663f54b3e7b551de2ceff8f7104a97f64741f8e5a02e2ef9b3d4e09806c26ba85e75c39c9ab99dc5019437db780f23dc1bb629 SHA512 5015a339ac4f0aa9a08942396f97c667602c760491cccb85ff8ef807f1be47d4e3c66a4145c5064c19ec8657ddac02a9ae88f460ab2e1c3394348de100879c90
DIST python-igraph-0.9.0.tar.gz 3366754 BLAKE2B baab83753bea4ee880564fe189b246c2ce0647a74ea1a41299062c3a2e203ec155abe1a3680c228d62a28e7bbf263e60e4529f151094b916ce4a1cae9f360705 SHA512 bd6071fc20c6c8f65034c71be6083e66367eb3047f376eb603e590da3606338fbd9890a2a74b8e0547fba2900c353f952683ea69b4d996f5643e84ee1c450b03
diff --git a/dev-python/python-igraph/python-igraph-0.8.2.ebuild b/dev-python/python-igraph/python-igraph-0.8.2.ebuild
deleted file mode 100644
index 0b2883896..000000000
--- a/dev-python/python-igraph/python-igraph-0.8.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface for igraph"
-HOMEPAGE="https://igraph.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/igraph
- dev-python/texttable[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? (
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- distutils-r1_python_compile --use-pkg-config
-}
diff --git a/dev-python/python-igraph/python-igraph-0.8.3.ebuild b/dev-python/python-igraph/python-igraph-0.8.3.ebuild
deleted file mode 100644
index 749126cdc..000000000
--- a/dev-python/python-igraph/python-igraph-0.8.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface for igraph"
-HOMEPAGE="https://igraph.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/igraph
- dev-python/texttable[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? (
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- distutils-r1_python_compile --use-pkg-config
-}